338
Views
13
Comments
Error opening file: The extension source code is already being edited in the IDE
Question
Hi

Here follows a tip. If you receive the error presented below, when trying to open a XIF in Integration Studio, follow these steps:
  1. Select Start / Run...
  2. Write %HOMEDRIVE%%HOMEPATH%\Local Settings\Temp\Integration Studio
    and press Enter, to open explorer in your folder C:\Documents and Settings\<USER>\Local Settings\Temp\Integration Studio
  3. Delete all *.lock files
--------------------------- Error ---------------------------
Error opening file: The extension source code is already being edited in the IDE.
---------------------------
OK
---------------------------

Regards,
António
Rank: #19200
Hi,
I have this problem but i can't solve it as you described.
I search every *.lock files in my computer, delete them and nothing.. i get the same error..

Do you know other way to solve the problem?

Best regards
Rank: #784
Hi,

You have to delete some temp files.
I guess it's C:/Windows/Temp folder files, i don´t remember that well.

Cheers,
Fernando
Rank: #19200
Hi, thanks for your reply.
i did that, but not solve may problem :S.
I make the same extension again because i did't find the problem..

thanks again,
regards
Rank: #118
Were you able to resolve this problem?  I'm having the same issue.
Rank: #19200
Hi,
To solve the problem I've had to implement a new extension. Otherwise could not solve.

Best regards

Rank: #9115

I came across this same issue. If anyone else has this what worked for me was deleting the locks and folders at 

"C:\Users\<your username>\AppData\Local\Temp\Integration Studio\". 

I know this is an old thread however it was the first thing that popped up when searching for the error so it might help anyone else trying to solve this bug.

Rank: #57869

Had the same issue and this worked for me Carlos. Thanks!

Rank: #88

Carlos Lopez wrote:

I came across this same issue. If anyone else has this what worked for me was deleting the locks and folders at 

"C:\Users\<your username>\AppData\Local\Temp\Integration Studio\". 

I know this is an old thread however it was the first thing that popped up when searching for the error so it might help anyone else trying to solve this bug.


Thanks Carlos
Its working.

Rank: #1434

Carlos Lopez wrote:

I came across this same issue. If anyone else has this what worked for me was deleting the locks and folders at 

"C:\Users\<your username>\AppData\Local\Temp\Integration Studio\". 

I know this is an old thread however it was the first thing that popped up when searching for the error so it might help anyone else trying to solve this bug.

Thank you for sharing Carlos, this worked for me.


Rank: #5998

Carlos Lopez wrote:

I came across this same issue. If anyone else has this what worked for me was deleting the locks and folders at 

"C:\Users\<your username>\AppData\Local\Temp\Integration Studio\". 

I know this is an old thread however it was the first thing that popped up when searching for the error so it might help anyone else trying to solve this bug.

 Thank you so much!

 

Rank: #7408

Thank you Carlos! it worked :)

Rank: #316

Thanks Carlos, That works!

Rank: #9926

Thanks deleting the lock file worked! on another note, this issue appears to still be occurring after 12 years...