Sending SMS: 'Virtual phone not configured for entry MySMS'

Sending SMS: 'Virtual phone not configured for entry MySMS'


I'm getting this error message whenever I try to send an SMS assynchronously in an action flow. There is no need to have user interaction (handling sms response,etc.)...

Can someone point me where to find info on fixing this issue?

Thank you,
Pedro Gonçalves
Hi Pedro

This error message appears when you have an application with a SMS Flow or SendSMS nodes and you haven't configured the ApplicationPhone for it.

In order to do that you'll need to map your ApplicationPhone, from your eSpace, to an existent Service Center Phone. To check for the phone, get to Service Center, Administration section and go to the Phones page. If you don't have any listed Phones you need to create one, real or fictitious (for testing purposes only).

Then, access your eSpace details and navigate to the Application Phones tab. On your ApplicationPhone press Assign and select the Phone you've got or created in Service Center. You can assign it by Keyword or MSISDN.

If you don't have a valid SMSGateway connection and configuration, you can use the fictitious Service Center phone to queue inbound SMSs, and check the OutBound SMSs from the SMS Logs at Service Center Monitoring section. This will allow you to test your SMS Flows without sending real SMSs to mobile devices.

Hope it helps.


Miguel João

I'm starting to learn SMS flows.
Message Queuing Component, required to send and receive SMS, are not correctly installed. Application runtime erros might occur.

How can I install a Message Queues? Do I need to do that in order to "test" my eSpace?

You said something like "fictitious Service Center phone to queue inbound SMSs".. is this what I need to do?

I already assigned my ApplicationPhone to the Phone.

Please explain to me step by step as this is my first time.
Hi Victor,

Welcome to the community and I hope you have a good time using the OutSystems Platform. Now dor the answers to your questions:

To install Microsoft Message Queues:
1 - Open Control Panel
2 - Add/Remove Programs
3 - Add/Remove Windows Components
4 - Message Queuing
5 - Check Common
(You might be prompted for your Windows XP/2003 installation CD's)

To use OutSystems Service Center to queue an inbound SMS:
1 - Go to OutSystems Service Center
2 - Administration
3 - Phones
4 - Select a Phone from the list (assuming you have already created one)
5 - Click the "Queue SMS" link

Hope this helps,
Tiago Simões
Hi Tiago,

I still can't make it work.. it getting me out of my mind... I already saw 2 sample's movies "Queue SMS (Service Center)" and "SMS Screens and Command Editors" but none of them helped.

Do I need a SMS gateway to make it work?

I've installed the Message Queue from XP but when publishing Service Studio keep saying it's not installed..

I'm sure I have sucessfully associated my eSpace with the Phone number

Phone 913456789

Priority eSpace Tenant Application Phone Keywords
1 Workflow - ApplicationPhone LIST | LI | L

I've tried both method Sharing By Keyword and Sharing By Msisdn (not sure what's the difference thought)
By the way the Tenant field is "-" none, is this normal? I checked SQL and I'm sure the Phone Number is associated with the correct Tenant_ID... only doesn't show in Service Center

When I try to send message to Queue SMS to 913456789

"OutSystems Service Center has encountered an error."

What I understand is that the MSISDN 913456789 is the device associated with the eSpace... so in the Message Input I should send command like LIST or LI or L... and then the device 913456789 should reply to me with the correspond action (List a content or whatever...)

I also try to "Send Message" in my Web Flow to the ApplicationPhone but it also get an error message:

Details:The queue does not exist or you do not have sufficient permissions to perform the operation.

Really don't know how to make it work..

Please help. Thanks!
not sure if is relevent but I went to the ServerSetup, in Gateways tab I hit the Test Connection button unsucessfully. Is this behaviour normal?

I'm using localhost, laptop, Windows XP, Service Studio
Hi Victor,

Have you restarted the OutSystems SMS Connector Service after installing MSMQ? You can do this in Control Panel>Administrative Tools>Services. Maybe you should restart all other OutSystems services too.
If you are only testing, maybe your best option is to use "Share by Keyword" method. It is natural that the tenant id field is -, since you must be working with a single-tenant eSpace.
Also, in serversetup it is natural that the connection to the Gateway is unsuccessful, unless you configure an sms gateway which, since you are only still testing, you don't want to do.
To see your messages you can go to OutSystems Service Center>Monitoring>SMS Logs.

Tiago Simões
Hi Tiago again,

Yes.. I tried that before, reboot the machice so many times.
Now I also stopped the service manually in the Start Menu -> OutSystems -> Administration Tools -> Stop Services and Start Services...

I've checked the Administration Tools in XP and all OutSystems services are started, restarted, etc... but still it doesn't work. When publishing it keeps saying that Message Queues is not installed bla bla...

What next? Please help........
Hi Victor,

Sorry, I forgot an extra step you must do.
You need to open serversetup and click OK so that OutSystems services can start using MSMQ.

Tiago Simões
Hi Tiago,

Yeap right, it was missing that step. But now I have another question.
According to what I understood, in Service Center Queue SMS I can send Msg to the eSpace ApplicationPhone1... and in the SMS Log I can see the message that I sent...

But where do I see the response of my Application? I mean the interaction with my device.. I think I am suppose to send some commands to the device like "List or L".. and according to the command the device will response to me.... but where I can see those response?

I also understand that an iSMS flow can be Initiated by the End User (Queue SMS method?) or Initiated by in Another Flow... I've try both method in my eSpace but nothing happen after sending the message...

Actually I don't even know if the ApplicationPhone have received the message....

I believe my eSpace is all correct, I just don't know how to test it.

Now I found out in General Log:
2007-11-20 16:55:07

24 24 SendSms Called, The node received has type ssWorkflow.node8303StartiSMS1, Large Account: 913456789 MSISDN: 123456789 INFO

That's the SMS that I sent using "from Another Flow" method...