Deployment failed due to the missing module

Deployment failed due to the missing module

  

I have been facing this problem since morning and nothing is progressing due to the deployment failure. Below is one of the failure screenshot.

Another error is


Please share entire error from Service Center.

Suraj Borade wrote:

Please share entire error from Service Center.

How do i go to service centre?


Open Service Studio

Click on this control

Go to monitoring

There search for  errors related with this eSpace.

Or type your entire server name and then add service center in browser

dev.xyz.com/servicecenter

Go to monitoring

Oh sorry. I doubt if this error would be saved on servicecenter or not. Please copy, paste this error message.

Suraj Borade wrote:

Open Service Studio

Click on this control

Go to monitoring

There search for  errors related with this eSpace.

Thank you for the quick reply. Yes, I have been there and found that there is a messages that states as, "New broken or missing reference found for producer module .. please review and republish.."

During the deployment, i got a message as dependencies were missing as they were deleted. Infact they were never dependant on this application. That was a different application for test purpose. I have deleted that, as it is not having any importance. The deletion of that application is causing the problem

So after deletion of unwanted dependencies your issue resolved?

Suraj Borade wrote:

So after deletion of unwanted dependencies your issue resolved?

No. I still see that as a challenge on every publish. The below popup is continuing on every publish. Surprisingly, now the app is throwing 503 error 



Solution

This could be a typical situation of dead lock. I have the DB entities as a different solution and the project as a different solution. While working with the main solution, if the solution of DB entities is published, this kind of situation arises ..

Thanks everyone in helping me in this journey

Solution