Asset Manager

Has anyone tried out Asset Manager?
I can't successfully set up any other IP besides
I'm using target machine's domain admin credentials.

Hi Susana,

There are several reasons why IT Asset Manager might not be scanning other computers:
- In the Settings tab make sure you have a valid IP Range;
- Make sure you can ping other computers from the computer where OutSystems Express Edition is installed;
- Are you not finding computers at all or are the computer details not being scanned? In the later case it can be problems with permissions or related to firewalls (in the server or in the remote machines - you can follow the "configuring your firewall" link in the FAQ page to learn how you can handle this).

Let me know if any of these helped.
Tiago Simões
Hi, Tiago.

Thanks for your reply.

IP ranges are valid.
I'm able to ping all of the servers I want to target.
The message I keep getting when I test the IPs is "IP not matched". I don't know if that means that ITAM can't find the computer or if it means ITAM just can't get the details.

I'm almost 100% sure that there are no firewalls between ITAM and the servers I'm targeting.
Susana Domingos
Hi Susana,

Please try to add one specific IP address in front of the others, in the "IP Ranges to Scan".

For example, say you have ";;" and want to test for "".

In the "IP Ranges to Scan", change it to ";;;". Did it work?
António Melo
Tried that, too; still doesn't work.
I've checked WMI logs on target machines, as well - the only thing i get there is "DllCanUnloadNow is returning S_FALSE", which seems to be unimportant.

ITAMs Overview page displays the folowing message:
"It seems there are some connectivity problems to your server. Please check your connection.
IT Asset Manager will keep trying in the background."
Does thta mean abything significant to you?

Many thanks for your interest.
Hi Susana,

Seems there is a problem with the Test feature in IT Asset Manager settings page and we'll fix it for the next version. This should not have any impact in the scanning thought.

What is the range you are trying?
Please note the syntax: is valid is not valid.

We have an issue to support both syntaxes or at least validate them on the UI.
Let me know if any of these helped.

Tiago Simões
Hi again, Tiago.

Thank you for your support.
I am aware of the syntax and am using sinlge IP addresses.

I did make some progress, though: I changed the logon account for WMI on some of the target machines. ITAM is now able to list some of the machines it didn't list before (alas, some remain unreachable) but in that list they are stated as being firewalled (Win2K SO), although they're not.

Still struggling!
Susana Domingos

Have you tried to run this command in the target machines?
c:\> netsh firewall set service remoteadmin enable
This enables scanning computers that have windows firewall.

You can also use the Group Policy editor - Gpedit.msc (See attached image) to globally make this changes across your network.

If you are using other firewall software you need to permit these ping Inbound ICMP commands - 0, 3, 8 and 11.

Read this article on MSDN to know more about WMI connections through firewalls:

Tiago Simões

Windows 2000 doesn't have a firewall and I've not installed one.
No Group Policies preventing WMI.
I'm still checking with our network admins if there are firewalls between our server (where I've got ITAM running) and or workstations.
Susana Domingos
I have exactly the same problem in one windows 2000 machine. No firewall, nothing...

The only thing not entirely correct is the fact that that machine has something in the event viewer about DCOM errors. Maybe yours has too?


Hi Miguel and Susana,

Have you checked out if you have DCOM configured properly in all machines?
You can read the procedures here:

Also bear in mind that some connections between operating system versions are not supported and others have special requirements:

Tiago Simões