String was not recognized as a valid DateTime

String was not recognized as a valid DateTime

  
Hi, i currently uploaded an oml developped in 4.0.55 version..

When i uploaded to hub server 4.1 the same oml, i got the error String was not recognized as a valid DateTime , and by debugging noticed it came up when a comparison with a site property was made...

Here is an example where debug stops :

ComboAddresses.ReturnedRowCount < Site.NrAddrPerEntity ...

NrAddrPerEntity is defined as an integer, and RowCount is an integer as you know....

How could i work this around?

Best Regards,

Diogo CS Cordeiro
I suspect it's a bug and will report it to support....

It's no only with comparisons....

A strange thing that is happening is :

in the following example, I have 2 site properties, one that is a datetime(Property2), and the other is an integer (Property1)


I have a single webscreen with an input, whose variable is Site.Property1 and an ok button to reload the page...(which is a bit useless)

Can anyone try this oml and check if the same error appears?

Best regards,

Diogo CS Cordeiro
Hi,

It looks like the problem is related to the site property default value and to the cast between datetime and date data types. Our support team will take a deeper look into the issue but for now, if instead of #1900-01-01# you use #1900-01-01 00:00:00# as the default value and change that site property value in OutSystems Service Center, it should start to work normally.

Cheers,
Tiago Simões
Thank you Tiago, it solved my issue....

Best Regards,

Diogo CS Cordeiro