Populate InputBox from Entity attribute on change of dropdown

Populate InputBox from Entity attribute on change of dropdown

  

Hi Team,

Need your advice for populating Inputbox from entity attribute based on dropdowm selection.

We have a Form created from Project Entity, this entity has attribute,

  1. Sites – Identifier for Sites Entity.
  2. Currency - Text

On Project Form, combobox (Sites) is populated from Sites aggregate. This Sites entity has attributes (SiteName, Currency, BG, etc).

Now on our form, when user select Site from Combo box, Currency textbox should populate with the value which is stored for selected site.

I did some test with Label, it is working with Label and I can see label value is changing with Site change. However, this same implementation is not working for inputbox.

For Label: I am using local variable (currency) which is populated on Site Change.

This same variable is then used for InputBox (Currency).



Please advice, 


Thanks,

Hello Z M,

Are you refreshing the Inputbox container after changing the dropdown value?

And another thing, you are assigning the NullValue to the value you want to display, you must change that too.

This might be the issue.

Best regards!

Paulo Zacarias wrote:

Hello Z M,

Are you refreshing the Inputbox container after changing the dropdown value?

And another thing, you are assigning the NullValue to the value you want to display, it will not work like it is right now.

This might be the issue.

Best regards!

Hi Paulo,

Yes, I am refreshing both InputBox and Label. I can see refreshed value in label but not in inputbox.

Thanks.


Z M wrote:

Paulo Zacarias wrote:

Hello Z M,

Are you refreshing the Inputbox container after changing the dropdown value?

And another thing, you are assigning the NullValue to the value you want to display, it will not work like it is right now.

This might be the issue.

Best regards!

Hi Paulo,

Yes, I am refreshing both InputBox and Label. I can see refreshed value in label but not in inputbox.

Thanks.


You should change the NullValue of the input box Z M.

Best Regards


Paulo Zacarias wrote:

Z M wrote:

Paulo Zacarias wrote:

Hello Z M,

Are you refreshing the Inputbox container after changing the dropdown value?

And another thing, you are assigning the NullValue to the value you want to display, it will not work like it is right now.

This might be the issue.

Best regards!

Hi Paulo,

Yes, I am refreshing both InputBox and Label. I can see refreshed value in label but not in inputbox.

Thanks.


You should change the NullValue of the input box Z M.

Best Regards


Tried with NullValue, no change. Not sure what is missing.


Thanks,

Solution

Leave the highlighted attribute as blank Z M.

Solution

Paulo Zacarias wrote:

Leave the highlighted attribute as blank Z M.

Thanks Paulo, It worked.  appreciate your quick help.




You are welcome Z M.


But have you understand the reason why it was happening? You were assigning the Null Value to the value that you in fact wanted to show, so, it would never show it.


This Null Value attribute is quite useful when you want to do exactly the opposite of what you were trying to do.


Best regards!

Paulo Zacarias wrote:

You are welcome Z M.


But have you understand the reason why it was happening? You were assigning the Null Value to the value that you in fact wanted to show, so, it would never show it.


This Null Value attribute is quite useful when you want to do exactly the opposite of what you were trying to do.


Best regards!


Yes I do understand now, Thanks.