https in email

  

I have created an email screen with a link built-in that points to my outsystems application. Each link is pointing to a screen in Outsystems. However they create a http link. Now I like the links in the email to use https, instead of http.

How would I do do that?

- Our system already has a SSL certificate present.
- I've set the UI flow configuration to: HTTP Security = SSL / TLS

Still the links are http.
Anyone has any idea?

Hi Paul,

A quick test reveals me that you were on the right track: setting HTTP Security to something else than None turns the link into a https link instead of an http one.

Since you indicate it doesn't work in your case, are those screens you link to in the same eSpace as the e-mail screen? If not, did you refresh the references after changing the HTTP Security setting and publishing?

Do I need to set the HTTP Security setting to SSL in both the e-mail UI flow as the Screen UI Flow that is being linked to?

And yes they are in the same e-space. I made two different UI flows though, 1 for emails 1 for webpages.

Solution

OK the solution was to set the screens to SSL.

You also need to set the screen that is being linked to on SSL.

Solution

Ok, that's not what I saw in my example, but then again, they were in the same flow. Great you found the solution.

Hi All,

I have the same issue but my email is triggered from a process flow when a record is inserted in a table. I have modified the pages to https security but still my link URL in email shows http. 

Any help in this regard would be very much appreciated. 

Thanks,

Kunal