[Google Maps] Google Maps API Version

[Google Maps] Google Maps API Version

  
Forge Component
(20)
Published on 9 Mar by Steve Collins
20 votes
Published on 9 Mar by Steve Collins

Hi there,

I am getting the following error in Chrome Dev tools when using the Google Maps map.

Is there something that I can do to remedy this or is it a update that is necessary from the forge's side?

The link takes me to the following message:

Thanks,

Hi Tjaart,

This seems like an interesting problem, hope you get it solved asap.

Kind Regards

Werner

You might be able to edit the version somewhere, wasn't there a Site Property you could use to indicate the version? It might stop working properly though if some things got deprecated.

Claring wrote:

You might be able to edit the version somewhere, wasn't there a Site Property you could use to indicate the version? It might stop working properly though if some things got deprecated.

Hi Claring, 

I have tried to "Support" (for lack of a better word) other components in the past, but just ended up chasing my own tail, therefore my request to the community on the component itself.  


Thanks for the response


I'll take a look at it.

Solution

Update:

So in ServiceCenter, go to the Factory tab and locate the Google Maps application.
Now open click on the Google_Maps espace/module click on the site properties tab and and in here you can change the APIVersion.

The current version is 3.29 and seems to be working fine for me.

There might be some changes in the newer version so let me know if you still need any help after changing the version.

Solution

Hi Claring,

Very nice info, I will be applying it to my managed servers right now.

Hi there,

I made the change in the Site properties and it seemed to have done the trick. 

Thanks