Bug in RichMail on server ?

Bug in RichMail on server ?


I'm trying to send email using RichMail extension from OHE revision

When using LOGIN authentication type the server ( MDaemon 9.6.2 ) kept telling me my authentication type was unrecognized.

This was the conversation between the server and the SMTP server:

--> 220-mail.infosistema.com ESMTP MDaemon 9.6.2; Mon, 12 Nov 2007 11:17:55 +0000
--> 220 Unauthorized relay prohibited.
<-- EHLO expowin2k
--> 250-mail.infosistema.com Hello expowin2k, pleased to meet you
--> 250-ETRN
--> 250-AUTH=LOGIN
--> 250-8BITMIME
--> 250-STARTTLS
--> 250 SIZE 0
--> 504 Unrecognized authentication type
<-- dGVzdA==
--> 500 What? I don't understand that.
<-- MTIzNGFiY2Qh
--> 500 What? I don't understand that.

As you can see you have AUTH<space><space>LOGIN intead of AUTH<space>LOGIN having an extra character before the LOGIN word. I'm using a direct site property with no space, and triple-checked the reference to that site property I'm not putting that extra space.

Can you check on your RichMail extension code, if is there anything wrong there? Maybe this is nothing special for non "picky" smtp servers, but ours is very strict.

Best regards, and tx in advance
Hi João Cesar,

There is indeed an extra space between AUTH and the authentication name (thanks for pointing that out, we'll change that for future versions), but I'm convinced that is not what is causing the refusal from the server.

The fact is, at present, the RichMail extension only supports PLAIN and "regular" LOGIN authentications. CRAM-MD5 extended logins are currently not supported, though an issue exists for that to be implemented some time in the future.

Hope this helps.


"but I'm convinced that is not what is causing the refusal from the server. "

I'm not convinced, I know that is that what is causing the refusal from the server.

After making telnet to smtp server i manually made AUTH LOGIN and he accepted.

If i give him 2 spaces on the telnet, he refuses with the same error that i get from outsystems logs.

So that is really the reason :)

When can I expect a patch?

Best regards.
Hi again,

Upon closer inspection I see what you mean: the server is reporting that it can handle CRAM-MD5 but you are not actually trying to request it, so please disregard my previous comment. As you mention, your particular server does seem to be quite strict, as to the best of my knowledge this is the first time we've had this situation reported.

In regards to the patch, I'm not able to give you a time estimate as I am not part of the Maintenance team, and therefore not aware of their current release schedule. Can I suggest that you report this issue to the OutSystems Support team so they can forward it through the proper channels, please?

Best regards,

Hi Miguel,

Idd, he is strict, but he is forcing compliance on the RFC.

I think the only non RFC compliant mode they accept is AUTH=LOGIN, but other than that will not be sucessfully parsed. A trim at start would solve the problem for them.

Anyway, thanks for your time, we will disable authentication for specific internal sending emails, so we can overcome this fast, and we will be waiting for a fix on next releases.

Best regards