[OutSystems UI Mobile] LightboxImage Error

[OutSystems UI Mobile] LightboxImage Error

  
Forge Component
(31)
Published on 4 Oct (14 days ago) by OutSystems R&D
31 votes
Published on 4 Oct (14 days ago) by OutSystems R&D

Hello.

I found an issue on LightboxImage and need your help to fix it.

I've attached a demo project showing the error.

Steps to reproduce:

1) open c3 app (it can be done on web browser or mobile device)

2) click on the "user" image at the main screen

3) close expanded image

4) click "tela 1" button

5) click agin on the "user" image at the "tela 1" screen

6) click on back button to go to the previous screen

7) click on the "user" image and this time we've got the below error


Hope this help you to find a solution.

Cheers.

Luciano Guimaraes

Hi Luciano,

I can not get the behavior that you mention. Do you have the latest version of the Silk UI Mobile component?

Cheers,

José

Hi Jose. Thanks for answering.

I think so. Please see below image showing version 1.5.1 installed.

Did you try my sample "c3" app to reproduce the issue ?

Cheers

Luciano


Hi Luciano,

Yes. I did try it.

Regarding your screenshot, I'm not entirely sure that does mean that you have the latest version... Could you check the date of your install (in Service Center) and compare it with the date of the latest version? Or install it again...

Cheers,

José

Jose, is that what you need ?



My first attempt was to update SilkUI and even after that I could not get it working fine.

You can access my c3 app on https://lucianodltec.outsystemscloud.com/c3/

If it helps I'm avaiable to update (again) the SilkUI. Please let me know how can I help you to help me :-)


Cheers

Luciano

Hi Luciano,

I can not reproduce the error in your app. But maybe that is because I can not do step 6: what back button are you talking about?

Cheers,

José

This is a very important step.

I mean the "back to previous page" (left arrow) on the top of the browser.

Without this step you cannot reproduce the error. I guess it is something related with restoring previous screen state.

Please, try again this way and you'll be able to see the problem. If not, I'll do a video showing it.

Cheers

Luciano


See below what button I mean...

It's equivalent to the Android back button.



Hi

We are already aware of this small error and we are working on a solution. Soon there will be a release with the solution.

Thanks

Hi Luciano,

Just to let you know that in the end I also got that error. And as stated in the post above they are working on a solution.

Cheers,

José