Graph empty when exporting to PDF

Graph empty when exporting to PDF

  

Hi,

I'm having some trouble when creating a pdf with a graph in it. I've created a webblock for displaying the graph on a page and use the same webblock for the page that's used to create the pdf. When I call the URL directly I see the graph as I want, but when I supply the same URL to the HTML2PDFConverter I get everything in the PDF, except for the graph.

I Thought that maybe the webblock was the problem, so I tried and put the graph directly into the page, but that's not working either. Also played with the chartFormat (i.e. UseAnimation = False), but that didn't solve it.

Has anybody some fresh insights on this?

I'm using Platform Server 10.0.708.0 and Service Studio 10.0.709.0

Below the screen grab from the PDF:

Below the screen grab from the directly called page:

Thanks in advance!

Menno

Can you post the url that you passes in the HTML2PDFConverter ?

Solution

Hello Menno,

I never tried to convert to PDF a page with graphics.
However, I would like to ask you something.

Are the page you are converting making use of any "session variable" in order to define the data to use?
If so, this would be a problem, as the executable that converts the page does not have access to the application context and than, the page when called by it is in a different session.

Also, GetUserId() will not work by the same reason.

Cheers,
Eduardo Jauch

Solution

Hi Eduardo,

The page itself not, but I just noticed that a piece of logic (server action) has session variables in it. I knew about the different context you mention, but not about the session variables in the logic. I'll adjust that and let you know.

Thanks.

@Filipe : I can not give the exact URL because of security reasons.


Hi Eduardo,

Yep, that did the trick!

I replaced (almost!) all session variables, but forgot two...

Thanks,

Menno


Hello Menno,

Good to hear it worked.

Cheers

Eduardo Jauch