Server and configured database have different encryption keys

Server and configured database have different encryption keys

  

Hi Team,


we are trying to install Outsystems 9.1 and while Apply and Exit on Configuration tool - getting below error-Oracle is used as database -

“This server and the configured database have different encryption keys. Copy the private.key from outsystems  installation of a machine that was connected to this database and try again.”. attached is error.


This is the only app server ever connected to database. We have already tried to uninstall Outsystems and re-install but same error. Can anyone please help ! 

Thanks

Salil

Hi Salil,

Have you seen this post:

https://www.outsystems.com/forums/discussion/22035/platform-upgrade-private-key-file-error/

Maybe on a different context but it has the same error as you. 

Cheers,

José

Hi Jose,

Thank you for reply.

I've seen the post and tried re-installing but did not try database scripting fix. are you recommending for database script too to be run.


Thanks,

Salil



Hi Salil,

That reply actually comes from here:

https://success.outsystems.com/Support/Enterprise_Customers/Maintenance_and_Operations/Migrate_an_Environment_Using_a_Database_Clone?origin=d

Check specially the security context parts.

Cheers,

José

Hi Jose,


Its looks really informative, let me try and share the findings :)


Thanks.

Hi Jose,

I tried the above steps and could 'Apply and Exit' configuration tool. but now error got change. attached is error screen shot. it's about failure in deploying service center.

Can we have a call to discuss it, if possible.

Thanks

Salil



Hi Salil,

Does the server where you are installing the environment has access to the internet?

You can PM me and we can discuss it further.

Cheers,

José