[Multiple Select] Multiple Select -- Listbox does not fill parent, too narrow to be of any use

[Multiple Select] Multiple Select -- Listbox does not fill parent, too narrow to be of any use

  
Forge Component
(14)
Published on 2014-05-02 by André Madeira
14 votes
Published on 2014-05-02 by André Madeira

A similar posting was addressed in June.

Using a ListBox and MultiSelect where the Listbox is set to fill the parent and it does in ServiceStudio.  But when the page is served, the Listbox is narrow, too narrow to use.  

Adding a 'document ready' wrapper to the creation function was suggested as a solution: https://www.outsystems.com/forums/discussion/25449/narrow-multiple-select-control-when-listbox-is-fill-parent/#Post94281

My question is that I have added the '$(document).ready' to a couple of places including the root function and the Multiselect Function, regardless of where I put it, the MultiSelect does not render at all.  Just the standard list box.  Not sure where to put or the exact form.

Any help or suggestions would be appreciated.

EDIT:  I just realized it's the Forge Multi-Select Component you're talking about.  I'll have to give that a try.  However... since the ListBox Widget allows for mutli-select, why do you need the Forge component?

I'm really new to OutSystems, but I had created the ToDo Web App.  In the Categories page of that app I added a ListBox, Multi-Select, and set the Width to (fill parent).  It seems to be ok.  Is this what you're referring to?

Davidk wrote:

EDIT:  I just realized it's the Forge Multi-Select Component you're talking about.  I'll have to give that a try.  However... since the ListBox Widget allows for mutli-select, why do you need the Forge component?

I'm really new to OutSystems, but I had created the ToDo Web App.  In the Categories page of that app I added a ListBox, Multi-Select, and set the Width to (fill parent).  It seems to be ok.  Is this what you're referring to?

The ListBox works fine.  I need the look and feedback from either the MultiSelect or Chosen Forge component which does not work in a SilkUI application.


Could you elaborate on the "MultiSelect" part?  I understand the Forge "Multiple Select" component isn't working for you.  It was created 3 years ago... under version 8...so not too surprised.

Are you saying that you want to use a ListBox, with the MultiSelect option, to render items in the List that are marked in the data source as selected?  Is that the problem?

If that's the case, then I edited my data and marked a couple of data items as selected.  Then I ran my page again and those items are selected in the ListBox and fill the width of the page.  This is a freshly rendered page... with 2 rows showing as selected... per the data.

Davidk wrote:

Could you elaborate on the "MultiSelect" part?  I understand the Forge "Multiple Select" component isn't working for you.  It was created 3 years ago... under version 8...so not too surprised.

Are you saying that you want to use a ListBox, with the MultiSelect option, to render items in the List that are marked in the data source as selected?  Is that the problem?

If that's the case, then I edited my data and marked a couple of data items as selected.  Then I ran my page again and those items are selected in the ListBox and fill the width of the page.  This is a freshly rendered page... with 2 rows showing as selected... per the data.

I am looking for the additional functionality of the MultiSelect and Chosen controls from the Forge.  The multiple selection capability or function of the unaltered ListBox control has never been the issue.  

I am trying to take advantage of the visibility of the selected items and also like MultiSelect's "Select All / DeSelect All" piece.  Additionally, both have search capability built in....