[Excel Package] Issue on "Cell_WriteText" Action

[Excel Package] Issue on "Cell_WriteText" Action

  
Forge Component
(4)
Published on 2 Aug by Carlos Alfaro
4 votes
Published on 2 Aug by Carlos Alfaro

Hello,

Thank you for this handy component that I always use whenever I need to generate a report directly from the system. It helps me a lot.


I am currently using component as well and it is my first time getting this problem.

I use Cell_WriteText action where the text inside it should be :

SyntaxEditor Code Snippet

GetEntity(GroupByEntity.List.Current.GroupByEntityId).Entity.Description + " (" + GetCountry(GroupByEntity.List.Current.GroupByCountryId).Country.Name + ")"


But whenever I generate the file, it wil be separated into 2 columns which is not what I expect (picture attached).


Do you have any idea what might be the root cause?

I appreaciate any kind of help.

Thank you.


Hello Maya,

I've created a small test eSpace (attached), that just creates a new Workbook and, using the Cell_WriteByIndex action, writes in the first cell, similar to your example. 

The test works as expected, the written text is not broken into two cells.

Are you using the latest version of the component?

Thank you.

CA

Carlos Alfaro wrote:

Hello Maya,

I've created a small test eSpace (attached), that just creates a new Workbook and, using the Cell_WriteByIndex action, writes in the first cell, similar to your example. 

The test works as expected, the written text is not broken into two cells.

Are you using the latest version of the component?

Thank you.

CA

Hello Carlos,

I've found the root cause.

It only happens when

GetEntity(GroupByEntity.List.Current.GroupByEntityId).Entity.Description

 has "coma" character inside it.

E.g :

Outsystems Co., Ltd

it will be separated into : "Outsytems Co." and ", Ltd"

If I replace the coma with another character, everything works well.

I don't know whether this is the version issue or the component limitation.


Thank you :)


Hello Maya,

I've tested with "OutSystems Co., Ltd" (code attached) and it still is only writing to the first cell, without separation.

Did you check it you are using the latest version of the component? The underlying EPPlus library was upgraded to the latest version.

Thank you.

CA

Carlos Alfaro wrote:

Hello Maya,

I've tested with "OutSystems Co., Ltd" (code attached) and it still is only writing to the first cell, without separation.

Did you check it you are using the latest version of the component? The underlying EPPlus library was upgraded to the latest version.

Thank you.

CA


Hallo Carlos,

Thank you for your help.

I agree it's due to the difference of the version.

:)