10tabs widget duplicates the same tab

10tabs widget duplicates the same tab

  

Hello community,

I am using a CustomWidgets - Tabs10, there are 10 tabs and each has its own content.

The problem is after Content6, the remaining tabs display what's in content6.

I don't know how to fix it, any help?


thanks in advance!

Hi Basma El Moadadi,

Without knowing how the Tabs10 component was implemented, it's not easy for us to determine what's going on... Can you provide more information, maybe even a sample OML with your Tabs10 component?

Hello,

Upon request, here is the OML.

Hello Basma,

In the oml you provided everything seems to work fine for me?


Hi Basma El Moadadi,

Please check the value extende property of your Tab10's Tab7, Tab8, Tab9 and Tab10 placeholders. All those placeholders are assigning Entities.Tabs2.Tab6 to the value extended property.


Nick Vandebriel wrote:

Hello Basma,

In the oml you provided everything seems to work fine for me?


that's the thing, when i use it in my application it does not work like expected!


Jorge Martins wrote:

Hi Basma El Moadadi,

Please check the value extende property of your Tab10's Tab7, Tab8, Tab9 and Tab10 placeholders. All those placeholders are assigning Entities.Tabs2.Tab6 to the value extended property.


Hi Jorge,

how can i view the extended property? thanks.


Update: it is working now. I just deleted it, then re-dragged it to my web screen.

Thanks everyone!

Hi Basma,

Below is extended property "title"


Regards

-SK-

It just happened the same issue to my project.

I am using 7 tabs and previously everything is working fine. UAT passed and my project is in Production.

Now, tab header passing parameter become "Entities.Tab6"  after Tab 6 for the rest of the tabs until Tab 10.

And Tab 7 content UI CSS class is using "Entities.Tab8".

I am really surprised that how these values are changed without my knowledge. I copied the whole control to my project and I don't have any dependency on Tabs 10 widget module.

And I also facing some issues which are previously working fine.

1) TenantSwitch function

Previously, it is just implicit logout. So I can continue to do my flow seamlessly and no need to login again.

Now, it logout explicitly. So after I call to that function, I am stuck in login page.

2) NullTextIdentifier

Previously, I am sure this function taken care of both NULL and EMPTY string.

Now it is only taken care of NULL. So I have to put another filter for EMPTY string like MyString = ""

I am a bit scared of those functional behavior changes as these are the only few things I just notice. And I have tons of usage of those functions in all other projects.

Can someone from Outsystems explain about these changes?

Thanks.