Empty Search Keyword Session Variable with web block is referenced

Empty Search Keyword Session Variable with web block is referenced

  

Hi, 

I have this web block (list screen) with a simple search functionality with a session variable (search keyword - text) link to it.

When this web block is referenced in an other espace, then the simple search functionality does not work, i debugged it and saw that the session variable is always empty although I entered a value.

I replaced the session variable with a normal variable and then it works fine.

Pretty strange, can someone please help me with this.

Thanks,

Cyril

Hi Cyril,

So if I'm understanding correctly, you have an eSpace that has a Web Block, and that Web Block stores the search text in a Session Variable that is also defined in that eSpace?

That is a common pattern and should work, even if the Web Block is referenced from another eSpace. See attachment for an example, which you can test here.

Hi Kilian,

Thanks for your reply.

The situation is exactly as you said and is indeed a common pattern.


The only thing I can think of is some programming error then. Session variables work quite well usually :).

Solution

And now it works! 

The web block was in a Tabs widget and for it to work, the property of the Tab Load on Click had to be on "True".

Thanks Kilian.

Solution

Cyril Bregieta wrote:

And now it works! 

The web block was in a Tabs widget and for it to work, the property of the Tab Load on Click had to be on "True".

Thanks Kilian.


Strange behavior! What is the Platform version that you are using?

Thanks for sharing.

Miguel Sousa wrote:

Cyril Bregieta wrote:

And now it works! 

The web block was in a Tabs widget and for it to work, the property of the Tab Load on Click had to be on "True".

Thanks Kilian.


Strange behavior! What is the Platform version that you are using?

Thanks for sharing.

Hi Miguel,

Version 10.0.704.0.

Regards,

Cyril