Express edition and java web services

Express edition and java web services

  
Hi everyone,

Is there any known problem or limitation in using java developed web services with the express edition?

I've tried with several of then and the only ones I had success with are the ones made with .net...
All the java ones return some kind of error like:
"Tried to invoke method public java.lang.String Distance.getCity(java.lang.String) with arguments java.lang.String. The arguments do not match the signature.; nested exception is:
java.lang.IllegalArgumentException: java.lang.ClassCastException@30d5aa "

or

"Method xyz.something can not be reflected.
The header property/field blablabla is missing or not public.
at System.Web.Services.Protocols.SoapReflector.ReflectMethod(LogicalMethodInfo methodInfo, Boolean client, XmlReflectionImporter xmlImporter, SoapReflectionImporter soapImporter, String defaultNs)"

Any ideas about what is going on or am I doing something wrong?

Thanks,

Francisco

Hi Francisco

The OutSystems Platform (either the editions) allows you to integrate through Web Services directly with Service Studio, that generally comply with the WSDL 1.1 specification (SOAP 1.1 or SOAP 1.2).

There are a few scenarios where these web services are not supported for Service Studio direct consumption, but are always able to be imported through custom development with an Integration Studio extension. These rare scenarios may involve multi-port listening, multiple namespaces and name clashing across namespaces, external dependencies, overloaded methods and recursive data, or "any" type objects definition.

From the stacks you've provided, in this case, it seams that the Java web service is expecting method arguments that don't comply with the provided signature.

Can you tell us what framework is generating these web services, and provide us with the WSDL (Web Service definition file) of that web service for analysis?

Thanks

Cheers

Miguel João

Hi João,

The 1st error was from a web service I was using for tests. The wsdl can be found here:
http://webservices.imacination.com/distance/Distance.jws?wsdl

The one that worries me is the 2nd one.

It's a Documentum web service developed with the documentum framework 5.3 sp 4.
The weird part about it is that we used a simple c# app to test it - using the same web service and calling the same methods - and it worked ok...
The wsdl for this service is attached.

Regads,
Francisco
Hi Francisco

Sorry for the late answer.

A few days ago, we've tried to access the http://webservices.imacination.com/distance/Distance.jws?wsdl web service, and got the same exception during runtime when calling the getCity method. At the time it seamed that the Web Service itself was having an argument type mismatch problem.

However, today, after further testing, all went ok. Can you try the web services again?

Thanks

Cheers

Miguel