[OutDoc] Error Unable to cast object of type 'ServiceStudio.Expressions.ParsedExpression'

[OutDoc] Error Unable to cast object of type 'ServiceStudio.Expressions.ParsedExpression'

  
Forge Component
(29)
Published on 11 Jun by OutSystems R&D
29 votes
Published on 11 Jun by OutSystems R&D

Hello team

I used OutDoc to generate documentation on my web app. The app has 20+ eSpaces and extensions. When I generated the documentation via solution, all eSpaces and extensions ran without a problem except for one. 

I refreshed all references, published a new solution and tried to generate the documentation again, but the error was still showing.

I tried  to generate the documentation for this eSpace alone, but then again, no luck.

Can you guys help me out on this? I've attached both the error message on OutDoc and the error thrown on service studio.


Thanks in advance,

Ângelo

Hi Ângelo,

without a reproducible oml it will be hard to explain the problem. 

Are you allowed/able to post the oml?

Otherwise, to pinpoint the problem, you can debug inside OutDoc or create a clone of your oml and delete parts by trial and error until you pinpoint the element that is causing the problem. 

Kind regards,

Remco Dekkinga

Hello Remco, and thank you for replying

I did exactly that. I cloned the module, and narrowed the source of the problem to a web block. Howerver, there's nothing apparently wrong with that webblock, as it compiles and runs perfectly on my application.

I've also noticed other people reporting the same problem I'm having (here), so is it possible that this is an issue with OutDoc itself? 

Best regards,

Ângelo

A new version of OutDoc that should solve the reported problem has just been published.

Please try it out and let us know if the problem persists.


Thanks!