Timeout in long running timer-action

Timeout in long running timer-action

After 2 minutes, a long running timer-action is timed out, i now it is a setting in the .Net 2.0 configuration. Can anyone tell where to set it.
Hi Matthias,

Take a look at Miguel João's 4th post in http://www.outsystems.com/NetworkForums/ViewTopic.aspx?TopicId=3486

Hope that helps.

Hello Matthias

If you are talking about the OutSystems timers, their timeout is not controlled by any .NET 2.0 setting, but instead by the timeout setting that is defined for that timer. In Service Studio, you can change this setting when creating the timer; in Service Center, you can change this setting by accessing Factory | eSpaces, choosing your eSpace and clicking the Timers tab.

We find it strange that you mention 2 minutes, since the default timeout is of 20 minutes. Is this a typo or are your timers really aborting after 2 minutes?

Found it, in .Net 2.0 you have to set the Timeout in the Machine.config:

in the section <system.web> the line <httpRuntime maxRequestLength="65536" executionTimeout="300" /> must be added.