Forge Component
(36)
Published on 2018-11-23 by Johan den Ouden
36 votes
Published on 2018-11-23 by Johan den Ouden

Hello,

When pruning old versions I get this error:
The DELETE statement conflicted with the REFERENCE constraint "OSFRK_OSSYS_ESPACE_OSSYS_ESPACE_VERSION_PENDING_VERSION_ID". The conflict occurred in database "JF8A83004", table "dbo.ossys_Espace", column 'PENDING_VERSION_ID'.
The statement has been terminated.

Any idea what's wrong?

Hello Niels,

Please check my answer to this issue on https://www.outsystems.com/forums/discussion/14691/error-application-db-cleaner/


I believe it covers it.

Best regards,

Or this one.

You have to update a new one. The old version does not support the correct version removal