SQL Server connection String

  

Hi all!


I am having trouble with my string connection in Service Center to create my database connection with SQL Server.

Can someone upload a example or photo of a possible string connection, precisely, a localhost server name?

Thanks.

Hi Anselmo,

In here you have some examples:

https://www.connectionstrings.com/sql-server/

Does this help? If not, what type of string are you trying?

Cheers,

José

Yes, thank you very much! But I got another problem.

"Connection String test failed: A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)"

My firewall is off for domain.
I am trying to connect the platform with a localhost and now I have 0 clues of what's going on.
Any tips?

Hi Anselmo,

You are saying that you are trying to connect with a localhost. Does that mean that the platform and the database are in the same server?

Cheers,

José

Hi, José!

Exactly.
That's a problem?

Thanks,
Anselmo.

Hi Anselmo,

No. Not a problem. Just trying to understand. :)

In that case you have nothing to worry regarding the firewall.

Is your database engine configured to accept remote connections?

Check this out: https://stackoverflow.com/questions/18060667/why-am-i-getting-cannot-connect-to-server-a-network-related-or-instance-speci

Cheers,

José

Hi!


I just dived in your link but still didn't find an answer.
I tried every solution in my sight....that's really complicated. :(


Thanks,
Anselmo.

Hi Anselmo,

Try to check your connection without trying to use OutSystems.

Here is another link. :)

https://knowhow.visual-paradigm.com/hibernate/solving-sql-server-connection-problem/

Cheers,

José

Hi!

It seems that is some kind of problem with my TCP/IP configuration...I couldn't use a telnet command.
But the configuration are enabled and in the default port (1433).

Thanks,
Anselmo.

Hi Anselmo,

In some case, especially on sql server express edition, the tcp/ip connection to your server is disabled.

So you need to configure it. Try this procedure to do that: https://stackoverflow.com/questions/9138172/enable-tcp-ip-remote-connections-to-sql-server-express-already-installed-databas

Best regards

Fabio Fantato

Hi Fantato,

Tried the options in your link but still having the same problem.
I don't know why, but my feelings say that it is something with the fate that the platform and SQL Server are on the same server.

Thanks,
Anselmo.

I did install several envs with platform and SQL on the same machine, I´ve never seen this.

Do you try to disable the firewall?. I know they are on the same machine, but Windows is always a surprise.

Some SQL installation don´t related the instance and the host automatically. 

So, try both strings :  localhost\instancename , 127.0.0.1\instancename or only localhost or only 127.0.0.1

(locahost on windows 2008 or above is linked to ipv6(:1) and not the 127.0.0.1)



nselmo Saito wrote:


Hi Fantato,

Tried the options in your link but still having the same problem.
I don't know why, but my feelings say that it is something with the fate that the platform and SQL Server are on the same server.

Thanks,
Anselmo.