Table pagination not reset after data chante.

Table pagination not reset after data chante.

  

HI, 

In the table below some data with pagination and currently the table showing the data of page no 4

save image

Now the Metric changed to Hourly, in hourly metric we have less amount of data ( not required pagination) but the pagination is showing like below.

save image

Means it is not resetting the pagination. If page 1 is clicked then the data is showing and pagination disappeared 

save image

How to reset pagination on data change?


Thanks

Sowvik Roy

Hi,

Is possible to share an espace with this problem? Is your ajax refreshing table and pagination? which values the pagination is using?

Regards,

Marcelo

Hi Sowvik,


Have you used Richwidgets property "List_Navigation_ResetStartIndex" . 

-Hitesh-


Marcelo Ferreira wrote:

Hi,

Is possible to share an espace with this problem? Is your ajax refreshing table and pagination? which values the pagination is using?

Regards,

Marcelo

Please find your answer in screenshots below.



Hi Sowvik,

As Hitesh already said, if you are Filtering your data, or putting new data in, you need to reset the pagination using the List_Navigation_ResetStartIndex() Action from RichWidgets.

Kilian Hekhuis wrote:

Hi Sowvik,

As Hitesh already said, if you are Filtering your data, or putting new data in, you need to reset the pagination using the List_Navigation_ResetStartIndex() Action from RichWidgets.


Hi Kilian,

Now the flow is like below. It's not working for me.

Thanks

Sowvik Roy

Well, it's difficult to see from that screem shot whether everything is ok. Does the "refresh" also refresh the pagination web block?

Kilian Hekhuis wrote:

Well, it's difficult to see from that screem shot whether everything is ok. Does the "refresh" also refresh the pagination web block?

Yes, Kilian the refresh is container,  contains both table and the pagination web block.

Thanks,

Sowvik Roy


Solution

What are you actually experiencing? Is it just the pagination that goes wrong? If so, do you pass the right TableRecords widget Id to the Reset_StartIndex()?

Solution

Kilian Hekhuis wrote:

What are you actually experiencing? Is it just the pagination that goes wrong? If so, do you pass the right TableRecords widget Id to the Reset_StartIndex()?


Thanks Killan, I had passed Pagination Web block id instead of Table Record ID.

Regards,

Sowvik Roy

Hi Sowvik,

Glad you solved it :)