[OutDoc] OutDoc - Missing Entity "Exposed Read Only" Attribute

[OutDoc] OutDoc - Missing Entity "Exposed Read Only" Attribute

  
Forge Component
(29)
Published on 30 Oct by OutSystems R&D
29 votes
Published on 30 Oct by OutSystems R&D

The "Exposed Read Only" attribute is missing from the XML:

<Entity Key="Entity:NDvzc2bNckOztrh6Lw7yGg" Description="...." Name="UserDelegation" Identifier="Attribute:UOfpNpINyEGlV1v7YQGQvQ" LastModifiedBy="...." LastModifiedDate="2017-12-01 20:03:26" Public="Yes">

But is being parsed:

       

Is there any possibility to add it?

Thanks,

Renato

Hi,

could you  share the oml .i will look into it and try to help you.

Hi Vijay, thank you for the reply.

I think the problem lies in the EspaceMetaModel extension from Outsystems not in the OML.

This extension converts an OML to XML.The XML output does not contain all the attributes, like the "Exposed Read Only".

Outsystems needs to change this extension to include the missing attributes.

Cheers,

Renato

Vijay Malviya wrote:

Hi,

could you  share the oml .i will look into it and try to help you.



renato0307 wrote:

Hi Vijay, thank you for the reply.

I think the problem lies in the EspaceMetaModel extension from Outsystems not in the OML.

This extension converts an OML to XML.The XML output does not contain all the attributes, like the "Exposed Read Only".

Outsystems needs to change this extension to include the missing attributes.

Cheers,

Renato

Vijay Malviya wrote:

Hi,

could you  share the oml .i will look into it and try to help you.




i agree with you.