[Social Sharing Plugin] Missing dependancies

[Social Sharing Plugin] Missing dependancies

  
Forge Component
(0)
Published on 6 Mar by Experts
0 votes
Published on 6 Mar by Experts

When i open, there is a Missing dependancies do you wish to update. MAy i know how to resolve this ?



Solution

Common Plugin is a dependency of the SocialSharingPlugin.  Just to confirm... do you have Common Plugin installed?

If you respond Yes to the update question... are Dependencies opened?  And can you click Refresh?  And then ok?

You write "when I open"... can I confirm what it is that you are opening?

I'm using 10.0.715.0.  I installed SocialSharingPlugin from Forge.  I opened a mobile project, and then opened Dependencies.  I found and clicked on SocialSharingPlugin in the Dependency List, then checked all branches for that plugin.

I published my app, closed it, opened it again, and I'm not getting any dependency messages.


Solution

Hi DavidK,

I tried to refresh and its working fine. Thanks.

Sorry, just wondering i am creating any mobile app and i do all the dependencies already. But i have an error, 


How do i makethe function available on the the home page for example?


thank you.

I feel you may be looking at this the wrong way.  You've posted an image of the Plugin logic flow... you shouldn't be in there.  Where is that logic flow?  In your app... or the plugin?  Something doesn't look right.  There's a number 2 after each section... e.g. CheckSocialSharingPlugin2.  This suggests you've got 2 references to the plugin.  Have you added the plugin code to your App?  If you have, that's wrong.  You just want the plugin dependency added to your app.  You then reference the dependency.

You have your mobile app.

You add SocialSharingPlugin as a dependency.

SocialSharingPlugin now shows as a Client Action in the Logic tab of your app.  There's nothing more to do specifically for the plugin... no other settings... nothing.

Add a Button Widget to your Home screen.  The Button Text can be "Social Sharing", and the Name of the Button could be btnSocial - not the Name of the Button Text... but rather the Button control.  In the On Click Event, choose New Client Action from the dropdown.  The logic flow of this new action will be displayed... just a Start and End.

Click once on the Logic tab and drag SocialSharing (inside SocialSharingPlugin) in between Start and End.


Then you enter an option Message, an Option URL, and choose a SocialType of Entities.SocialType.Twitter, .Facebook, or .All.  Twitter and Facebook are specific... All goes to everything else... e.g. GMail.

This is what you Button Client Action will look like...

Now... re-create your Mobile App... and re-install it... and when you press your Social Button... a screen will display showing you all the Social stuff you have installed on your device.  Select one.

Hope this helps a bit.






Hi David,

Did follow your method but when i click the button, there is no share to facebook.

Do i need to enter facebook url in the url option? i tried but nth happen. Let me play around with it.


Thanks

Do you mean that you are getting the popup when you click your button... and that items are there such as GMail, etc... but that Facebook is not there?  Or... you are not getting any popup at all?

If you are getting a popup, but Facebook is missing, that is because you don't have the Facebook app installed.

E.g. I did not have Twitter in the Social Sharing popup.  I installed the Twitter app... and now I have Direct Tweet and Tweet showing in the Social Sharing popup.

Hi, I am not getting a popup.. I have Facebook on my mobile but I click my button there isn’t any thing happenin


Thank you,

Kelvin

Ok... thanks.

Here's a QRCode for a sample app.  Not very helpful, but at least you can see how it's supposed to work.

Username: bob  Password: bobtest


Attached is the sample oml... I'm not sure if you can use it.  If not, post back, and I'll do a video walkthrough of how it's put together... takes about 5 minutes to build.

HI David,

Do i need to register as a app developer before this function will works? As i scanned and tried yours also no popup box on my mobile.


Regards,

Kelvin

Very odd.  It's an Android app... I was remiss in providing that info.

No... you don't need to do anything... it should just work.

What device and Android release are you using?


oh its only for android? i am using iphone actually.

You'd never be able to scan and use that QRCode then... or any QRCode code I sent.  iOS test builds must include device identifiers.

Let's back up a bit.  You write... "Do i need to register as a app developer".   Are you registered in the Apple Developer program?

Not yet, gonna do it later. Let me register and update u the status 

Thank you for the tutorial so far  :)

Are you testing on iOS by scanning the QRCode that OS provides when you test your app in a browser window?

Yes, i am testing on IOS. I scanned the QR code with the outsystems now app on my iphone

Ok... now this makes sense.  The OutSystems Now app is excellent.  It is, however, not appropriate in this case because it only includes certain plugins... lots of plugins... but it does not include the Social Sharing Plugin... and so could never work for you.  Here is a link to a list of plugins included...

https://success.outsystems.com/Documentation/10/Extensibility_and_Integration/Mobile_Plugins#What_Are_the_Supported_Plugins_Provided_by_OutSystems

The hands-down easiest way to test a mobile app with your choice of plugins is with an Android device.

With iOS it gets a bit complex and you need the use of a Mac (or very complex without the use of a Mac).

If your target device family is iOS then you'll need to register as a developer, and go through the process of creating a Certificate and Provisioning Profile.

For simple testing under Android... you don't need anything except a device.  I use my Nexus 7 (2013) for quick app testing... then move onto specific Android and iOS devices for target device testing.


Hi David,


I have managed to test it after registering as an app developer. Thank you so much for the help sorry busy with work last few weeks.

But just curious, in the box i entered "Test message" in the message field  but when i click share, the pop up box to share in Facebook is empty? Am i missing something?

Regards,

Kelvin