[FileSystem] File Move Issue - source path with 0KB file

[FileSystem] File Move Issue - source path with 0KB file

  
Forge Component
(20)
Published on 26 Sep (4 weeks ago) by Guilherme Pereira
20 votes
Published on 26 Sep (4 weeks ago) by Guilherme Pereira

Hello everyone,

Sometimes when I try to use the move action It leaves a 0KB file(source path). For instance if I have one file named "xpto" with 500KB and then move It to another directory(destination path) It creates a file named xpto in destination path with 500KB but leaves a file also named xpto with 0KB(source path),

Any of you got this issue? How did you solved It? 

Thanks in advance

@Fernando,

I checked the extension code and it is just using C# FileInfo.MoveTo to move the file in given destination. I tried the same code in example and is working expected (Moving File To Desired Destination Folder)


Regards

-PJ-

@Pramod Thanks for your reply.


Well, I have checked the extension code also. I guess the problem is there, on MoveTo or something like that. It happens sometimes, that's why I asked if someone got this issue.

@Fernando,

It can be a permission issue ..MoveTo basically moves the file from source to destination and than deletes from the source . Seems like it is moving all the data from source but not be able to delete the file and thus remains 0 kb file there.


-PJ-

@Pramod,

Can be but Its weird because works sometimes, I mean, the file is deleted. 

Thanks