.csproj files

  
Hi, I'm trying to create a SAP Proxy in Visual Studio, but everytime I try to edit the source code, I get this message: "Make sure the aplication for the project type (.csproj) is installed".

What do I need to download and install? I have Microsoft Visual Studio 2005 installed with the components listed in the image installed.

Thank's in advance for your help.

Best Reagrds
Hi Francisco,

You can check the Integration Studio Requirement (Development Tools section). Maybe you can download the free Microsoft Visual C# 2005 Express Edition.

Cheers,
Tiago Simes
It's not in the Integration Studio Requirement, but it also working with the free (and open source) SharpDevelop 2.2

http://www.sharpdevelop.com/OpenSource/SD/Download/
Hi Francisco

Also make sure you have the proper IDE Development Environment (Visual Studio 2005 for Integrations Studio 4.1 or Visual Studio 2003 for Integration Studio 4.0) configured on the Integration Studio Options dialog, accessible through the menu: Edit -> Options, on the .NET tab.

Cheers

Miguel João
Hi, I've been trying to work around a problem that came up with the instalation of C# 2008 express.

I finally succeeded on installing the software, after several attemps with errors. I uninstalled the previous versions of .NET Framework anf it worked. But now, I can´t access any pages on service center. When I execute the SCinstall.bat command i get the error in attach.

Couldn't life be a little bit more easy...? ;)

Thank's in advance for any help,

Best Reagrds,

FN
Hi Fransico,

I'm sorry but for now the only supported versions are the 2005 that you can download here:
http://www.microsoft.com/express/2005/download/default.aspx
(Microsoft Visual C# 2005)

Cheers,
Tiago Simões
Hi Tiago,

thank's for the tip. I tried the 2008 version because the 2005 was installing, so I decided to try the 2008.

I'm going to uninstall all .net and C#'s components and try again to install the 2005 version.

Thank's again for the help

FN
Well,

I installed .NET 2.0 and c#2005 with no problem (finally), but I still can´t access localhost and I get an error when running scinstall.bat (attached).
I still get the "under construction warning when accessing http://localhost but now I get a configuration error (also attached) and at the bottom of the page i get the message "Version Information: Microsoft .NET Framework Version:1.1.4322.2407; ASP.NET Version:1.1.4322.2407 "

Does anyone one know how to solve this?

I'm running on a Wondows server 2003.

Thans' again,

FN
Hi Francisco,

You could try the following:

1 - Run "C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis -i" in the command line (this will install ASP.NET 2.0)
2 - Open c:\program files\outsystems\service center\serversetup.exe
3 - Click Ok
4 - Confirm that SQL Server is running
5 - Run scinstall
6 - Go to service center and publish all eSpaces

Cheers,
Tiago Simões
Hey Tiago,

Thank's a lot for the help!! I was going around this problem forever and with no success!!

That just did it, simple!!

Thank's again!

Best Regards!!
Back to the original problem, and after installing the C# 2005 express edition, I still get that same message, that it can´t open .csproj files. The settings for .NET in integration studio are the defaults.

Is there anything I'm not doing?

Thank's

FN
Hi Francisco,

Are you sure Microsoft Visual C# Express is correctly installed? When you open up Microsoft Visual Studio 2005 and go to Help->About do you see Visual C# in the list of installed products?
Can you create a windows or console C# applications (File->New->Project)?
Also make sure Integration Studio options for .NET is using the same path as Visual C# Express in the start menu.

Cheers,
Tiago Simões
Hi Tiago,

That kinf of worked. I'm now able to open .csproj in c# 2005 express edition. But I needed to use the SAP Proxy, and as it is in the SAP wizard for integration Studio, I will need at least, the standard edition, which is not free, is that correct?

Once more, thank's a lot for the tome spent helping me,

Best regards,

Francisco Neto