Debugging in Chrome Issues

Debugging in Chrome Issues

  

Hello, I'm running a personal project from the cloud but I can't get it to actually run anymore. When I run the app in the emulator, it says that I need to update the version, it then tries to update, but immediately goes back to the original screen asking me to update the application. When I try to add breakpoints or use debugging I just get this error in chrome: "there was an error processing your request." 

I made some changes previously regarding local storage but nothing that I know of which would cause these issues. 

Hi John,

Did you check the service center log? It can give you more details about what it's happening.

Try also to ctrl+f5 on chrome to clear cache.


Vera Tiago wrote:

Hi John,

Did you check the service center log? It can give you more details about what it's happening.

Try also to ctrl+f5 on chrome to clear cache.


I tried clearing the cache but nothing seems to have changed. Here is the log I'm able to pull up on my phone: 


 OPEN database: 65acd789-3a52-40e0-bd2d-c3d364a10eec_bffc2a70-8acd-4bbd-bdb1-2ed71453957c
 OPEN database: 65acd789-3a52-40e0-bd2d-c3d364a10eec_bffc2a70-8acd-4bbd-bdb1-2ed71453957c, connection: connection1 - OK
 OPEN database: 65acd789-3a52-40e0-bd2d-c3d364a10eec_bffc2a70-8acd-4bbd-bdb1-2ed71453957c, connection: connection2 - OK
 OPEN database: 65acd789-3a52-40e0-bd2d-c3d364a10eec_bffc2a70-8acd-4bbd-bdb1-2ed71453957c, connection: connection3 - OK
 OPEN database: 65acd789-3a52-40e0-bd2d-c3d364a10eec_bffc2a70-8acd-4bbd-bdb1-2ed71453957c, connection: connection4 - OK
 Looking for something? Visit https://silkui.outsystems.com for documentation and samples :)
 ERROR: VersionsManager [2018-01-03T15:48:48.165Z]: Upgrade failed - rolling back to previous application version.
 Script error for "GroceryShare.entities"
http://requirejs.org/docs/errors.html#scripterror
 G@https://john-wood.outsystemscloud.com/GroceryShare/scripts/OutSystems.js?TgkYxm38WdiNZwCb45Sl2w:1:804
 onScriptError@https://john-wood.outsystemscloud.com/GroceryShare/scripts/OutSystems.js?TgkYxm38WdiNZwCb45Sl2w:1:12154
 OPEN database: 65acd789-3a52-40e0-bd2d-c3d364a10eec_bffc2a70-8acd-4bbd-bdb1-2ed71453957c
 OPEN database: 65acd789-3a52-40e0-bd2d-c3d364a10eec_bffc2a70-8acd-4bbd-bdb1-2ed71453957c, connection: connection1 - OK
 OPEN database: 65acd789-3a52-40e0-bd2d-c3d364a10eec_bffc2a70-8acd-4bbd-bdb1-2ed71453957c, connection: connection2 - OK
 OPEN database: 65acd789-3a52-40e0-bd2d-c3d364a10eec_bffc2a70-8acd-4bbd-bdb1-2ed71453957c, connection: connection3 - OK
 Looking for something? Visit https://silkui.outsystems.com for documentation and samples :)
 OPEN database: 65acd789-3a52-40e0-bd2d-c3d364a10eec_bffc2a70-8acd-4bbd-bdb1-2ed71453957c, connection: connection4 - OK
 ERROR: [2018-01-03T15:48:48.866Z]: Script error for "GroceryShare.entities"
http://requirejs.org/docs/errors.html#scripterror
 G@https://john-wood.outsystemscloud.com/GroceryShare/scripts/OutSystems.js?TgkYxm38WdiNZwCb45Sl2w:1:804
 onScriptError@https://john-wood.outsystemscloud.com/GroceryShare/scripts/OutSystems.js?TgkYxm38WdiNZwCb45Sl2w:1:12154
 OPEN database: 65acd789-3a52-40e0-bd2d-c3d364a10eec_bffc2a70-8acd-4bbd-bdb1-2ed71453957c
 OPEN database: 65acd789-3a52-40e0-bd2d-c3d364a10eec_bffc2a70-8acd-4bbd-bdb1-2ed71453957c, connection: connection1 - OK
 OPEN database: 65acd789-3a52-40e0-bd2d-c3d364a10eec_bffc2a70-8acd-4bbd-bdb1-2ed71453957c, connection: connection2 - OK
 OPEN database: 65acd789-3a52-40e0-bd2d-c3d364a10eec_bffc2a70-8acd-4bbd-bdb1-2ed71453957c, connection: connection3 - OK
 OPEN database: 65acd789-3a52-40e0-bd2d-c3d364a10eec_bffc2a70-8acd-4bbd-bdb1-2ed71453957c, connection: connection4 - OK

It seems you have some kind of "conflict" in the database. 

Do you have any entity called "GroceryShare"?

Vera Tiago wrote:

It seems you have some kind of "conflict" in the database. 

Do you have any entity called "GroceryShare"?

I have two modules: GroceryShare and GroceryShare_Core. GroceryShare_Core just keeps the database structure, while GroceryShare uses it as a dependency. I was essentially modeling this after the Todo tutorial which uses a similar design. 

Hi John, 

what about an incognito window, does it work?


Cheers,

Did you refresh the references? 

I did refresh the references and try putting the debugger into incognito mode. Nothing changed in the state of my application. 

Not the debugger, if you open your app URL on incognito window does it work?

I thinking there is a problem because of a previous merge I might have handled incorrectly. Is there any way to rollback or reset my application? 

Henrique Batista wrote:

Not the debugger, if you open your app URL on incognito window does it work?

In incognito mode, the emulator still does not work. 

Solution

The issue stemmed from a change I made in the local database in a previous merge. With the merge, I didn't mean to commit everything but for some reason, but it appears that there was a conflict between the local and server data and the application wanted me to update on loading. 

Thank you for all of the help everyone. I appreciate it. 

Solution