Mobile Multilingual problem when trying to publish

Mobile Multilingual problem when trying to publish


After making a small change to an existing mobile app, I'm trying to republish the app.  It was working fine and employs the multilingual module.  I'm getting the following error:

Publish aborted
New broken or missing references found for producer module 'MultiLingual'. Please review them and republish.

There is no additional information in the Error Log.  Any suggestions as to how to deal with this?  FWIW, I'm working in a Personal Environment.  Thanks!

  -- Joel

Hi Joel,

Open Producer module 'MultiLingual' and click to update references as shown below.

After that click on Refresh All button. If Refresh All is disabled then simply click Ok and publish the module after that.

In true change section, it will show how many modules are outdated now. Open those modules, repeat above step in those module and publish them. this should resolve your problems.

After refreshing the references, if you see any errors fix them.

Let us know if you need anything else.

Thanks and Regards,

Suraj Borade

Thank you, Suraj.

I'm trying to open the MultiLingual module to update the references, but I'm getting a message that "The module 'MultiLingual' is a System module and can not be changed.  Do you want to open a clone of the module?"

I shouldn't have to clone this system module in order to continue using it, should I?  I'm wondering if I need to delete the MultiLingual Mobile Component from my environment and try installing it again?  What do you think?

  -- Joel

Very interesting.  I just tried publishing again.  I didn't change anything, but now the publish worked!  I have to assume that OutSystems corrected something on their end.

  -- Joel