Timer Activation

Timer Activation

  

Hi,

I have uploaded the excel sheet and it will automatically create a timer for the entity. I have selected the timer to run when it is published. But i went to my timer log and see, the timer is deactivated. I have activated and apply the change but the timer still show deactivated. May i know what wrong?


Thanks

Hello Jace.

The timer gets deactivated automatically after it runs. That's normal behavior.

Do you have any evidence that the timer is not running?

Hi Jace,

I think you need to check timer log in service center so that you can verify last run or if any error occurred like below:

 

Regards

-SK-

leonardo.fernandes wrote:

Hello Jace.

The timer gets deactivated automatically after it runs. That's normal behavior.

Do you have any evidence that the timer is not running?

Hi,

For the timer schedule, i set it to run when it is published.

I put a breakpoint at the timer and debug it and realised that it did not execute the timer.



indra budiantho wrote:

it is because different session:

https://www.outsystems.com/forums/discussion/33621/schedule-timer-to-run-right-after-click-a-buton/

regards,

indra

Hi indra,

noted.. but how could we know that the timer executed? it is based on the timer log?


Hi Jace:

You can either:

- in the service center you can check in the 

- if you have no access to service center, in timer action : insert a record in an aggregate and then check whether the record is inserted


regards,

indra

Indra Budiantho wrote:

it is because different session:

https://www.outsystems.com/forums/discussion/33621/schedule-timer-to-run-right-after-click-a-buton/

regards,

indra

Timers indeed run in a different session, but that doesn't affect the debugger. You should be able to debug a timer.


Jace, did you start the debugger after you placed the breakpoint?