Freeze on Splash screen

Freeze on Splash screen

  

If i run my app for the first time, it will freeze on the splash screen. after that i must force close the app and open it again and it will run smoothly. What the loading progress for? because it look like the progress bar already in 100% but it will not go to home screen.

Hello Ervin. Does this problem happen in a new, fresh and empty mobile application? Just create a new one and try it out.

The progress bar is controlled by a block called ApplicationLoadEvents that is used in the Splash screen, together with a few events. There is an event called OnLoadComplete that is triggered when the progress reaches 100%. Please make sure that this event is being handled and ends up in a redirect.

Hi Leonardo,

Sorry for the late reply...

The problem didn't happened in a new fresh and empty mobile application. It only happen in this App. 

After looking at the logMessage, i've found that Percentage value never reach 100 and it stuck in 99. Why is this happening?

Could it be that your app uses something very large? Perhaps a big image, or a big javascript library? These files would be downloaded while the app is on the splash screen, and if they took too long you could think that the app is stuck.

Hi leonardo, at first our app's size is 30 mb. After deleting image, Excel Data, Bootstraps, and Timer, the app size become 10 mb. But the problem still occur. 

Hello Ervin. Is that the size of the app package that you install on the device? Or the size of the OutSystems module when you save it to disk in Service Studio?


Did you check if there's any error logged in Service Center?


Another thing that might be happening is that an offline synchronisation might be taking too long. You can turn off the synchronization and repeat your test to verify if that's the case. Take a look into this article, as it describes how you can turn off the sync on login (it's on step 4).

Hi Leonardo, that is the size of the OutSystems module. In my device, after install it, the size become 16 mb.

There's no error in Service Center. The weird thing that i notice's the percentage never reach 100 even after i waited for 5-7 minute.

As for the synchronization, our app already turn off the synchronization from the beginning.

Another update information,if i run the app using Outsystem now app, it will run smoothly. The problem only occur if i run the app using the native app package.

Solution

Hello Ervin. Your case seems tough :)

Can you create a support case, or at least share this app (even if privately by sending me a message)? I think that would be easier to troubleshoot.

Solution