Date Format Error

Date Format Error

  

Hi all,

I have the date formated in Service Center as "DD-MM-YYYY" as show below

And it shows as expected on page. But when I try to save it it gives me the validation error:


What am I missing here?

Btw i am using personal environment and an Editable Table.

Abílio Matos

Hi Abilio,


This should work as expected, could you please debug and share the validation message?


This you republish the entire factory? If you change the setting it's mentioned, you need to redeploy all the espaces.


Hope it helps you.

Solution

Daniel,


I did republish that eSapce since it was only one module on that espace.


But i did find out that i had to clear cache to this get to work.

So this is solved. 

Thank you.

Solution

Great glad that it worked!

I duplicated what you're seeing and then did a search for OutSystems Date Issues.  I found a couple of posts that confirm an answer.  Make sure that you re-publish your app (you've probably done that) and... here's the answer... clear your browser cache.

I cleared my browser cache, re-ran the app, and now dates are saved as DD-MM-YYYY - no errors.

EDIT:  Sorry... I didn't see your posted answer before I submitted.