Error when trying to consume Exchange SOAP Web Service

Error when trying to consume Exchange SOAP Web Service

  

Hello,

I'm trying to consume an SOAP Web Services exposed by our on-premise Exchange Server.

First, I tried to open the web service from it's URL, but it needs Basic Auth and this does not work in OutSystems. I tried to pass the username and password in the URL in username:password format, but it always return with an Not Authorized error.

Second, I saved the WSDL locally together with an types.xsd and messages.xsd files that it needs. When I try to consume the local file I get the error WSDL Load Error. No service descriptions found. It works when I use other tools, like SoapUI.

I've attached the WSDL and XSD files so you can try to consume it in an eSpace. Why is Service Studio unable to open that WSDL?


Thank you,

Liviu

Eduardo Jauch wrote:

Hi Liviu,

This does not solve your problem?

https://success.outsystems.com/Documentation/Development_FAQs/How_to_call_a_SOAP_web_service_with_authentication

Cheers,
Eduardo Jauch

Hello,

That's the article that I've read. It says to save it locally, which I did, then try to consume it. But I get No Service Descriptions Found. It works in other tools, like Soap UI.


Thanks

I think it has something to do with your WSDL linking to the messages.xsd and the messages.xsd linking to the types.xsd. 

Making a local copy of the WSDL and importing that is the way to go. But i'm not sure if you can have 3 files linked to each other. 

see also an other post: 


https://www.outsystems.com/forums/discussion/33385/wsdl-load-error-no-service-description-found/

Thanks, unfortunately I've read that post also. I've saved types.xsd and messages.xsd locally as well. The main wsdl points to them correctly, I think. The files are in the attached archive.


Thanks for your help

I've just tested something: I've removed the lines that import the messages.xsd and types.xsd files and removed the files from the file system. I stil get the No Service Descriptions found error.

Does anyone have any idea about what's wrong with the structure of the Services.wsdl file?


Thanks!

Hi Liviu Timar,

I am also facing the same issue, have you got the solution. It would be great if you share your solution..



Thanks

Narendra

Hi Narendra,

Unfortunately, no, I did not find any solution.

I decided to switch to REST web services. When working with Exchange, you can use the EWS Managed API in a C# extension.

Hope this helps.


Liviu

Hi Liviu Timar,


Thanks for your reply. Actually i am already explored Rest API's but due to business needs i am looking into SOAP.


Thanks..


Rgds,

Narendra

Hello,

Then let me ask you something: how do you get authenticated in the EWS Rest API? Do you use basic auth or it's integrated with Active Directory?


Thank you,

Liviu


Liviu Timar wrote:

Hello,

Then let me ask you something: how do you get authenticated in the EWS Rest API? Do you use basic auth or it's integrated with Active Directory?


Thank you,

Liviu


Hi,

Yes, I have two different scenarios where i am tested with OAuth 2.0 (Authentication with token) and Basic authentication. But still I am trying to fix the SOAP WSDL file to meet my exact need. 

 


Thanks,

Narendra


Ok, so you’re using Exchane Online. I am having difficulties with NTLM auth on-premises.


Exchange Soap did not work in Outsystems, so i gave up.


Thank you