Tooltip on hover in a line chart

Tooltip on hover in a line chart

  

Hello,

I'm using a line chart and I can't enable my tooltip on hover, only by selecting the data point.

I tried this:


plotOptions: {
        states: {
                hover: {
                    enabled: true
                }
            }       
    }


 tooltip: {
 enabled: true 
}


But it's still not showing.

Thanks in advance

Hi Filipa,

You should consult the Highcharts documentation. They have many examples, including a lot of jsfiddles so you can try to see what options you need to make things work.

Hi Filipa,

That should be the default behavior (if you are using the Charts that come with the platform): showing the tooltips on hover. No need to do anything.

Can you share a sample oml for us to see what is happening?

Cheers,

José

Kilian Hekhuis wrote:

Hi Filipa,

You should consult the Highcharts documentation. They have many examples, including a lot of jsfiddles so you can try to see what options you need to make things work.


Hi Kilian, sorry for the late reply. Yes, I'm using this but the hover tooltip features  I found there don't work.

José Costa wrote:

Hi Filipa,

That should be the default behavior (if you are using the Charts that come with the platform): showing the tooltips on hover. No need to do anything.

Can you share a sample oml for us to see what is happening?

Cheers,

José


Hi José,

I'm sorry, I can't share my oml due to copyright but I used the Line Chart from Charts module plain simple and the tooltip on hover doesn't show. Only by clicking in the datapoints.

Hi Filipa,

Can you check my oml? It's just the chart. And it shows the tooltips. Or maybe we are talking about different tooltips...

Another thing, which Theme are you using?

Cheers,

José

José Costa wrote:

Hi Filipa,

Can you check my oml? It's just the chart. And it shows the tooltips. Or maybe we are talking about different tooltips...

Another thing, which Theme are you using?

Cheers,

José


Hi José,

Thank you for sharing your oml.

Your tooltip only works by clicking on the datapoint, same behavior as mine.

I'm using the London theme.

Thank you

Hi Filipa,

Could you share a very simple oml with me?

I changed the Theme to use the London, and I still get the tooltips on hover...

https://josecosta.outsystemscloud.com/DemoChartsLondon/

Cheers,

José