SCInstall - Errors

SCInstall - Errors

  
Hello,

I have installed the HubServer v3.1.1 on a XP (SP2) machine , the
installation was ok, without no errors.

After when i try to configure the HubServer, i set the DB without
no problems but when i press ok in the config dialog it gives the error as
in picture Ousystems_HubServer_Error.bmp (in the zip).
But it seems to setup all ok.

After when i try to setup the control center (SCInstall.bat) it give the error
in picture Ousystems_HubServer_Error2.bmp (in the zip) , but the SC directory is created but not defined in the IIS.

Can you help me?

Thanks.

Best regards, Filipe Madelino
Hi,

Based on your error snapshots, please check in Microsoft Internet Information Services:
- if the "Default web site" is started
- if the Web sites property "ISAPI filters" has an entry for ASP.NET

Regards,
Paulo Silva
Hello Paulo,

Thanks for your reply. Yes my Default Web Site is running and the
ISAPI Filter for ASP.NET is set for the Web Sites node on the IIS
managment console.

But it seems that the ServiceCenter directory was set, only the
virtual directory was not defined.
I set it manualy. After i try to run the Web Service Center APP
and it gives me an error that i'm not authorized to see the page.

I have set the directory to have full permission to my machine
administrator and set the anonymous access to be impersonated
by the administrator. So I think that i should have access.
I also made another experience and remove the default
document feature and set the directory browsing option.
And i can see all the docs in the ServiceCenter virtual directory.

I think that the error of unauthorized access is raised when
it tries to find the datasource and he can not. There
any configuration parameter for defining the SQL Server database?

Thanks.
Best regards, Filipe Madelino
Hello Filipe,
I had a similiar error during my installation, but in my case it was due to the fact that i haven't executed the last 3 steps of the InstallCheckList.mht file, under the topic "Pre-Installation check list".

I missed the next steps:

- Configure SQL Server for ASP.NET SQL Server Session State:
In Query Analyzer execute the InstallSqlState.sql script.
You can get it from a Hub Node in <system drive>\WINNT\Microsoft.NET\Framework\version.

- Create HubState User and Set Its Permissions:
In Query Analyzer execute the SetupHubState.sql script.
You can get it from a Hub Node in <Hub Server installation folder>\db.
Or, You can download it from http://www.outsystems.net/SupportCenter/DocumentFromExterior.aspx?DocumentId=168

- Edit the machine.config file: in the sessionstate element, set the mode attribute to SQLServer and set the sqlConnectionString attribute to:
"data source=<SQLServerHost>;user id=HubState;password=outsystems".


I hope it helps.

Attachment: InstallChecklist.mht

Best Regards,
Ricardo Casaca
Hello Ricardo,

Thanks. I have missed that config steps.

But i follow your instruction and nothing, it gives
me the same unauthorized access message.

In the machine.config file for me to set the element
<sessionState mode="SQLServer" sqlConnectionString="Data Source=TUNIS\MAD;user id=HubState;password=outsystems" />

i have to comment the other sessionstate element

<!-- <sessionState mode="InProc" stateConnectionString="tcpip=127.0.0.1:42424" stateNetworkTimeout="10" sqlConnectionString="data source=127.0.0.1;Integrated Security=SSPI" cookieless="false" timeout="20" /> -->

since when i had the two it gives me an error stating that i can only
have one sessionstate element per config file??

Maybe this is related with the errors reported in my first post.
Can you check the attach.
Thanks.

Best regards, Filipe Madelino
Hi Filipe,
.NET only allows you to have one session state configuration in your machine.config, that's why you had to comment out the previous settings.

As for the problem with not being authorized it is sometimes due to the not having 127.0.0.1 listed in the list of internal network machines in the Hub Edition Configuration Tool and then accessing Service Center from the same machine via http://localhost/servicecenter/. You can find this setting in the Network tab of the Hub Edition Configuration Tool.

As for your original problem you posted, that error code in particular, points to problems with the Microsoft Internet Information Services metabase, which is where IIS stores all of its settings. Per Microsoft's recommendation the best of course of action is to re-install IIS.

Because this will affect the .NET Framework integration with IIS, I suggest you do as follows:

- Make a backup copy of "server.hsconf" (by default in C:\Program Files\OutSystems\Hub Server\)
- Stop all OutSystems services
- Uninstall OutSystems Hub Server (your settings will be preserved)
- Uninstall Microsoft .NET Framework
- Uninstall Internet Information Services (IIS)
- Restart your machine
- Install Internet Information Services (IIS)
- Restart your machine
- Install latest Service Pack for your OS
- Restart your machine
- Install .NET Framework
- Install .NET Framework SP1
- Install OutSystems Hub Server
- Open OutSystems Hub Server Configuration Tool
- Verify your settings are correct (import the backup copy of server.hsconf you saved earlier if not)
- Click "OK" to apply the configuration
- Run SCInstall.bat again

Best regards,
Marco Cunha
Engineering
OutSystems
Hi all,

After Marco Cunha instructions i have made all working.

But I only need to uninstall and install the IIS Windows component.
1) Uninstall the IIS Windows component
2) Reboot
3) Install the IIS Windows componente
4) Open the HubServer config and it works fine, now
it does not give the error that i refer in my first post.
5) Run SCInstall. It was set without no errors.
6) Run aspnet_regiis.exe (.NET Framework dir)
7) Set the SQL Server session for ASP.NET

After this i made it run OK.

All this because the IIS Metadatabase was danified.

Thanks to wall.

Filipe Madelino