Service Center - StackOverflow

Service Center - StackOverflow


I have installed HubServer which when i run SCInstall
gave me the error "String or binary data would be truncated". I get the revision and try again and gave me the same error.
Note that when upgrade i run the create/upgrade schema functionality on the
HubServer config utility.
I run the SQL Server trace tool i saw that the error was due to the size
of the columns of the tables "ossys_Extension", "ossys_Extension_Action"
and "ossys_Extension_Action_Param".
I increase the size of the Name, Description and sskey.
After i run the SCinstall and all works fine.

Why this behaviour? For instance the size of the Description field
on the table "ossys_Extension" was 50 (varchar) and in the
insert statments on the SCInstall execution we have descriptions greater
than 200 chars??
Is anything to do with the collaction of the Database instance?? Is a bug?

Ok, but this i have already resolve. It is just for understanding this behaviour.

My problem is after. I run the service center, i login as an administrator,
it show the interface for change the password, but when i set the
new password and press change it raises an exception. I have trace the
SQL operations and do not see any error.
I send a zip file which contains the exception message and the
web page that opens after.

Can someone help.


Best regards, Filipe Madelino

Hi Filipe,
the behavior you described with SCInstall having the columns too short is very peculiar. If all goes well and the necessary database user permissions have been granted to HubAdmin and HubRuntime the database should not experience that problem. I have just tried a clean install on a virtual machine without any problems.

As for the problem with the Stack Overflow, I'm assuming this is happening in your development machine because you have the under normal circumstance you'd never have the choice of launching a debugger and instead our error handling code would have run and the error would have been logged to our database.

From both problems you describe, there seems to be a problem with the database you're using for hosting OutSystems Hub Edition. My first troubleshooting suggestion is this:

- Try running the Hub Server Configuration Tool and granting permissions to the users. Assuming that happens without any problems try compiling Service Center again and login into it afterwards.

If you wish we can continue this via email, phone or we can continue using the forums, whichever suits you best. I'll post the resolution here in any case for the benefit of community. Let me know how this goes so we can continue troubleshooting this.

Best regards,
Marco Cunha