[Test Framework] Imported UTF test actions won't run

[Test Framework] Imported UTF test actions won't run

  
Forge Component
(14)
Published on 26 Mar by Indigo Leap
14 votes
Published on 26 Mar by Indigo Leap

Hi,

First let me thank you for developing and sharing this test suite project. It is exaclty what i was looking for to manage an increasing number of tests created with the UTF framework.

Today i've installed the latest version, unfortunately i run into a problem.

I tried to configure a test case with test steps from UTF. This is what i did:

Configure API Endpoint URL:
1. https://www.mysite.com/MyEspace/MyUTFTestWebservice.asmx

2. Click > Load UTF Tests

3. All test actions from MyUTFTestWebservice.asmx are added as test steps!

4. Now Run test

5. Error > Method 'MyUTFTestWebservice.MyTestAction' not found

6. All test steps give this error :(

Is there something i miss?

Any help very much appreciated.


Ben




Hello Ben,


Thank you for your feedback.


Today we will be publishing a new version, we have found a possible glitch on the UTF load process. 


We hope the problem will be fixed.


Best Regards

Nice!

If the new version is available i will try it out.

thnx

The version available at the "try now" option is already the last version. If you want you can try it from there.


Please PM with your findings

Thank you

I already uploaded the new version.


Please let me know if are still facing the issue.


Thank you,

Hi Davide,

I've installed the new version (both the framework and probe).
After install i've created a new test case and added a API test.
I entered the UTF test URL en imported the test steps.
So far so good...

But when i run the test, the test failed with the following error:


(System.Reflection.TargetInvocationException mscorlib)Exception has been thrown by the target of an invocation.

   at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
   at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)
   at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
   at System.RuntimeType.InvokeMember(String name, BindingFlags bindingFlags, Binder binder, Object target, Object[] providedArgs, ParameterModifier[] modifiers, CultureInfo culture, String[] namedParams)
   at OutSystems.NssTestFramework_SOAP_lib.WebServiceInvoker.InvokeMethod[T](String serviceName, String methodName, Object[] args)
   at OutSystems.NssTestFramework_SOAP_lib.CssTestFramework_SOAP_lib.MssSOAP_InvokeMethodManyResults(Object ssInvocationObject, String ssMethod, RLParameterRecordList ssInput, Boolean& ssSuccess, RLParameterRecordList& ssResult, String& ssErrorMessage)

CreateNewMember
     TestRunUnitTestId (Int32): 0


Any ideas?

Ben

Hello Ben,


Yes, I believe that it has to do with the definition of the variables, variable types.  Without further analyses I would suggest that you change the (int32) to just int. I had a similar problem on my testings.


Please let me know, if it worked.