Upgrade OHS 3.1.3.5 to OHS 4.0.1.8

Upgrade OHS 3.1.3.5 to OHS 4.0.1.8

  
Is there any compatible issues on upgrading to 4.0.1.8?
Where can i find an installation guide for 4.0 version? Is it the same as for 3.0 versions?
Are my 3.1 solutions compatible with this new version?

Thanks in advance!
Hi Ruben

Upgrading any version to the latest 4.0.1.8 of Hub Server, will imply that the Service Studio and Integration Studio must also be upgraded to at least Service Studio 4.0.1.7 and Integration Studio 4.0.1.6. Beyond this, if you follow the Hub Server 4.0 Installation Check List, as an Upgrade to a new release, you won't find any compatibility issues.

However, depending on the applications running, and their cyclic references, you may find compilation errors while republishing your factory in consumers eSpaces that still have producers in the old version. Hence, the best way to upgrade your applications is to republish all your extensions and eSpaces, producers first.

There's no Installation Guide for Hub Server 4.0 has it was for Hub Server 3.0, instead, we've improved the Hub Server Install CheckList for Hub Server 4.0, which is all you need to upgrade your environment. This check list can be found in the compressed installation file for Hub Server 4.0 or directly in Check list for Hub Server 4.0 installation.

I've you considering upgrading a production environment, we recommend to first upgrade a test or a development environment and perform application tests.

One final note, is the Hub Server license. In 4.0 the license platform has been improved, and 3.x licenses are not compatible with Hub Server 4.0, hence you must request a new Hub Server license, after you installed Hub Server 4.0. Just follow the procedures in the Request a New License link of the Administration->License page of Service Center.

Hope this information helps.

Regards

Miguel João