OneSignal plugin errors 503,504

OneSignal plugin errors 503,504

  

hi there, 

today we have problem with OneSignal plugin that have created by OutSystems expert , when we want to SetTag we get errors 503,504 please help me


regards,

omid

Hi Omid,

503 and 504 HTTP errors have to do with the destination not being reachable (503 = Service Unavailable, 504 = Gateway Timeout). This typically means you either specify a bad URL or there are some firewall or networking issues.

Kilian Hekhuis wrote:

Hi Omid,

503 and 504 HTTP errors have to do with the destination not being reachable (503 = Service Unavailable, 504 = Gateway Timeout). This typically means you either specify a bad URL or there are some firewall or networking issues.

Hi Kilian

when i am calling Register action everything is ok but my problem is with SetTag action in OneSignal plugin

if it was firewall problem i have to this problem with Register action also, but my problem is with SetTag action when i am calling SetTag action i get these errors in oneSignal Rest apis i do not know it's problem in onesignal website or it's related to onesignal plugin

in application ready event i Register device then call SetTag and i see these errors


Well, that's indeed what would be expected (and its usefull extra data). I would suggest you to repost your question in the component's appropriate forum, including the information that Register works as expected.

That said, have you tried to debug the problem? At what call does the 503 or 504 hit? The SetTag Action calls Editdevice, is that where it goes wrong? Do you provide it with the right Id, as the Id is part of the URL (I can see you getting a 503/504 in case the URL is wrong).