Consuming SOAP webservice with "any"

Consuming SOAP webservice with "any"

  

I'm trying to consume the webservice bellow, but I'm running into some issues (tried on 2 different environments with different Platform versions).

The webservice is working fine on Postman.


1. When I import the wsdl directly from the URL, the output variable is created as Text, so I used XMLToRecord in order to convert it to a RecordList. But the resulting RecordList is always empty. And the output of the webservice is always like this: oscotizador_core.webreferences.status.OSELEMsetStatusCotizacionResponse472449$SetStatusCotizacionResult@14d337a9

This is happening on both my Personal Environment (P10) and a 9.1 environment


2. The WSDL uses a sequence with "any", so I tried saving the wsdl to a local file and editing it with the proper XSD. The webservice definition is imported fine, but when I publish the espace, I get a NullPointerException error.

This is happening on a 9.1 environment.

When I try the same on the P10, the Output structure is always empty.


The original WSDL has this structure:

<s:element minOccurs="0" maxOccurs="1" name="getInfoCotizacionResult">
      <s:complexType mixed="true">
           <s:sequence>
                <s:any/>
           </s:sequence>
      </s:complexType>
</s:element>


Has anyone faced such an issue?

Thanks.

Just figured it out.

It's just another case of incompatible WSDL element on the platform.

The "any" element is not recognized, so the platform cannot match the structure in the response of the webservice call.

I had to mannually add the contents of the XSD within the WSDL. As everybody here must be already used to... :/

Yup, SOAP compatibility is a bit wanting...