Internal Error when using "Foreign Entities"

Internal Error when using "Foreign Entities"

  
Hello, i' currently upgraded the platform from 3.0.5.26 to 4.0.1.33, and by using integration studio, upgraded the old extensions. But when i tried to recompile some eSpaces, which use the foreign entities extension (automatically created by the upgrade), it gave an internal error. In one of them it was the following :

Internal Error
Invalid compiler output.
Exception Details:
[1] Internal Error: Invalid compiler output.

[2] System.InvalidCastException: Specified cast is not valid.
at OutSystems.HubEdition.Compiler.Entity..ctor(XmlElement elm, CompObj parent)
at OutSystems.HubEdition.Compiler.Extension..ctor(XmlElement elm, CompObj parentCompObj)
at OutSystems.HubEdition.Compiler.Espace..ctor(XmlDocument doc, CompObj parentCompObj, Int32 eSpaceVersionId, String testname, TypeMapper typeMapper)
at OutSystems.HubEdition.Compiler.Compiler.MainExec()
at OutSystems.HubEdition.Compiler.Compiler.Main(String[] args)


It passed the verify phase, but still gave that error.

I also tried to created a simple eSpace with only one web screen, but which imported all the foreign entities, and it also gave an Internal error, while when i published without the extension, no compiler error appeared...

Can you help me on this please?

Best regards,

Diogo Cordeiro
Hi Diogo,

Please try to perform a Consistency Check on the faulty eSpaces. To acomplish this, press CTRL + Verify icon. A popup window will appear asking you if you wish to perform a Consistency Check. Press yes.

Best regards,
Carlos Cabral
I did that....and the error was still there...

The problem is currently being followed by the support center...

Any and all suggestions are always welcome of course.

Thanks,

Diogo