Not able to find the outsystems username and password in users table

Not able to find the outsystems username and password in users table

  

Hi,

To add a role I am not able to access  "https://<environment>/users/" using my outsystems cloud username and password.and the same is not in the users table also.

how add a new role then??


There are three types of users.

1. OutSystems - the one you are using here in the forum. Editable in profile screen.

2. Service Center - a few developer accounts, editable in LifeTime.

3. User - one of possibly hundred users in your platform, editable by the modules.


Are you confusing type 2 and 3? I think you are trying to configure your Service Center/Service Studio user as if it was an application user.



More information about different types of roles at Understanding the difference between Service Center logins and Users login - IT Users vs Application Users.


Cheers,

Tiago.

Nuno Reis wrote:

There are three types of users.

1. OutSystems - the one you are using here in the forum. Editable in profile screen.

2. Service Center - a few developer accounts, editable in LifeTime.

3. User - one of possibly hundred users in your platform, editable by the modules.


Are you confusing type 2 and 3? I think you are trying to configure your Service Center/Service Studio user as if it was an application user.




So, what happens when you fire up a new PE ?

what users are created and which not?


Hi J,

I would say 3 "different" users are created and all with the same username (your email) and same password.

Cheers,

José

Hi sini,

Why do you say that you can not see the user in the User Entity? How are you looking for it? Using an aggregate in Service Studio?

Cheers,

José


Nuno Reis wrote:

There are three types of users.

1. OutSystems - the one you are using here in the forum. Editable in profile screen.

2. Service Center - a few developer accounts, editable in LifeTime.

3. User - one of possibly hundred users in your platform, editable by the modules.


Are you confusing type 2 and 3? I think you are trying to configure your Service Center/Service Studio user as if it was an application user.



Yes service studio user..

Wat I need is to set an admin role. For that i need to enter the http:\\cloud\users and then add role.

But am not able to enter that page, its showing my credentials are wrong 


José Costa wrote:

Hi sini,

Why do you say that you can not see the user in the User Entity? How are you looking for it? Using an aggregate in Service Studio?

Cheers,

José


Yes we are having a users table under system tab in data.I cant see my outsystems username and password in that table and also am not able to login to  the app that i have developed using outsystems login id and password.


Thanks


After reading the link I posted before, please check the User Provider defined in your module. 

Nuno Reis wrote:

There are three types of users.

1. OutSystems - the one you are using here in the forum. Editable in profile screen.

2. Service Center - a few developer accounts, editable in LifeTime.

3. User - one of possibly hundred users in your platform, editable by the modules.


Are you confusing type 2 and 3? I think you are trying to configure your Service Center/Service Studio user as if it was an application user.



hai Nuno,

To add roles in mobile application we follow this path (https://www.outsystems.com/forums/discussion/7399/how-to-manage-users-and-roles/)

For that am not able to login to (http://<SERVERNAME>/Users) with my outsystems username and pasword.



Have you tried admin/admin?

sini v r wrote:

Nuno Reis wrote:

There are three types of users.

1. OutSystems - the one you are using here in the forum. Editable in profile screen.

2. Service Center - a few developer accounts, editable in LifeTime.

3. User - one of possibly hundred users in your platform, editable by the modules.


Are you confusing type 2 and 3? I think you are trying to configure your Service Center/Service Studio user as if it was an application user.



hai Nuno,

To add roles in mobile application we follow this path (https://www.outsystems.com/forums/discussion/7399/how-to-manage-users-and-roles/)

For that am not able to login to (http://<SERVERNAME>/Users) with my outsystems username and pasword.



Hi Sini,

I have been facing the same issue as yours ( That am not able to login to (https://<SERVERNAME>/Users) with my outsystems username and password.) but i can login to (https://<SERVERNAME>/servicecenter ) and also to  (outsystems.com) with the same Username and password. 


Have you got the solution for the above query. 


Somehow I found this  but still couldn't figure out solution to the below problems.
It states what could be wrong but how to fix that ??
Complete newbie with Outsystems and facing this issue  

My login works in ServiceCenter but does not work in Users...

If you are having trouble logging in with a given username under Users, but are able to login just fine in ServiceCenter, your problem can be:

- an issue of multi-tenancy (somehow your user from Users got moved to a different tenant)

- your user in the Users provider is inactive

- your user in Users has a different password

- the entry for your Users object in the database has a different password, and you are not resetting it well

- Users is configured for external authentication [5] and the user does not exist in the external authentication system - so login is not possible.


In the opposite situation (you can login in Users but not in ServiceCenter) you were probably never created as an IT user. In that situation, request that a user is created for you under ServiceCenter / LifeTime.