[Multilingual Mobile Component] After Platform Update 10.0.804.0 Deployment Problem Issues

[Multilingual Mobile Component] After Platform Update 10.0.804.0 Deployment Problem Issues

  
Forge Component
(11)
Published on 4 Oct by OutSystems R&D
11 votes
Published on 4 Oct by OutSystems R&D

Hi,

After Platform Update 10.0.804.0 when  try to deploy from Development to Test enviroment we receive belowe error.

22-03-2018 08:50:01Module 'MultiLingual' was deployed with an old OutSystems Server version. Please publish 'MultiLingual' to fix it.



22-03-2018 08:50:01
Compilation Error.
referencesProxy\eSpace_MultiLingual_proxy.cs(31,38): error CS0117: 'ssMultiLingual.Global' does not contain a definition for 'GetStaticEntities'
        return ssMultiLingual.Global.GetStaticEntities(staticEntities, producersKeys);


Allthough we publish model multilingual the problem continues.

Could you please help us urgantly?



Hi Erhan,

It seems that module MultiLingual_proxy.cs does not contain some references. Open that module, refresh the references and try publish again.

Ok,

Thnks.

I don't know if this was solved already.

I had this same problem.

The problem occurred when I tried to deploy my application from one environment (dev) to another (test), and this error appeared 5 or 6 times. The problem was that the servers had been updated and needed to redeploy the indicated modules BEFORE deploying to the DESTINATION SERVER (test). It seems that in the process of deployment, when trying to compile my application in the TEST server, it verified that the references there were not correct. Once I did the publish process in all the modules that in the TEST server that appeared in the error, I was able to deploy my development application to test

I hope it helps.


Carlos