Aggregate error

  

Hello everyone

I'm experiencing a rather strange behavior on one of the screens on my web app

I have a button set to Navigate from WebScreen 1 to WebScreen 2. That button carries a simple input parameter (Data type: Entity A identifier)

In WebScren 2's Preparation I have an aggregate which only contains Enitty A in it, with a filter A.id = input parameter. i'm making a group by one text field and a sum on an integer field

While debugging, when the Preparation triggers, the input parameter has the correct value, it enters the aggregate (first thing on the Preparation flow) but for some reason, I'm unable to exit the aggregate. The debug just gets stuck there. When not on debug mode, the page isn't able to load and I end up being redirected to the browser's error page.


Even stranger, I query the same table in WebScreen 1 and it runs without a problem. I've already tried changing this to an Advanced Query instead, and even removed the group by and the sum, but I get the same problem


Any ideas on what might be causing this?


Thanks in advance,

Ângelo

Hi Ângelo,

Did you check Service Center for errors? What error is being triggered?

Can you upload your eSpace?

Cheers,

João

Hi Ângelo,

What's the error? Timeout? Do you have an incomplete transaction in course into SSMS for example?

Regards,

Hello João

Thanks for replying. I forgot to mention, I don't get any errors on Service Center


Unfortunately I can't upload the eSpace as this is hapenning on a client's project, and, as you can understand, it's not something I'm able to replicate on a personal app


Samuel M. wrote:

Hi Ângelo,

What's the error? Timeout? Do you have an incomplete transaction in course into SSMS for example?

Regards,


Hello Samuel

I don't get any errors on Service Center. I end up reaching the browser's error page telling me "Can't reach page"

If you are being redirected to an Error page I assume that an Exception is being triggered. 

Do you have your exception handler to log errors? If you have Log Error to "Yes", then you should get an error message in Service Center.

Do you get any additional information in the General Logs?

hi Sousa,

Did you try to remove that aggregate? Did it happen also to other aggregates?

regards

Hello everyone

I ended up removing everything from the screen and the Preparation and added things back one by one and it's now working. 

I may have defined some property with an incorrect value that was causing the problem


Thanks for your help

Glad to hear that you have solved the problem. Increment debugging is sometimes the best thing to do.

regards,



Some strange behaviour. it might be interesting to know what causes it. !?!