Access to SOAP Trace logs

Hi all,

I am experiencing issues connecting to a WebService and I would like to download the Soap Trace that is available from the INtegrations Menu in Service Center.

Despite having my logging level to "Full" I cannot see the Detail when web service invocations are made.

Is there any solution for this? I've seen it in other environments working and I cannot get to put this one with that same level of detail

Hi João,

I've followed those steps. I even found out that in Dev environment I don't have the Logging Level option. But in Production i do (and is set to Full)

After republishing my eSpaces i still can't see that detail.

Thank you for your help tho.

Hmm.. are there calls being made?

Your stack is .NET right? If it wasn't you shouldn't have that option even...

Yes, they are being made, I can see them in the Integrations Log, i just can't access the detail window I need. :(

I have 3 eSpaces, where the WebService is in 1 eSpace_IS, and I can define the logging level for that eSpace (and is set to full) in the integrations Tab

The remaining eSpaces (from where I consume the webservice) I don't have that option because there is no consumed web services.

But in the end, is one of the other eSpaces consuming an action from eSpace_IS?

And is that action the one who makes the call to the ws?

But I don't have any place to set the logging level to full on the eSpace that consumes the WebService. Where can I do it?

Thanks a lot for the help provided

I'm sorry Jorge.

You are correct! You set the level in the module that is consuming the WS.

What I was trying to say is that in Service Center you have to filter by consumer eSpace and not producer... in the case you are referencing actions from eSpace_IS that expose the call to the WS.

Hi João,

I'm not sure I've understood your last reply. If you want can you message my via PM?

If you have a module A consuming a public action in module B...

... and it's module B that calls the SOAP ws....

... the call will be registered under "module A"... not "module B".