PowerBi

  

I tried integrating the PowerBI module but it doesn't work correctly. I get the embedded window and a wattermark that says the information is not available. When I tried my report id in the saple app provided with the module, I get a "Bad Request" error.


Any help is more than welcome.


Thanks,

Hi Gonzalo,

What is the "PowerBI module"?

PowerBI?

Is the BI - https://powerbi.microsoft.com?


What did you do exactly?

Are you using Forge's component?

Can your Outsystems server sees you PowerBI server?


I have too many times seen someone trying to connect from personal environment to unexposed services in their laptop.

Hi,

I've created a integration between an OutSystems application and BI. Our approach was to use restful webservices and for security basic authentication. This worked well. 

I would go for this approach. In this way you can test the restful webservices from your Outsystems application outside PowerBi. In this way you can clearly distinguish between OutSystems and PowerBI issues.

Regards,

Matthieu

Kilian Hekhuis wrote:

Hi Gonzalo,

What is the "PowerBI module"?

yes, the module in Forge. Its used to embed Miscrosoft P0wer BI reports into apps developed with Outsystems


Matthieu de Graaf wrote:

Hi,

I've created a integration between an OutSystems application and BI. Our approach was to use restful webservices and for security basic authentication. This worked well. 

I would go for this approach. In this way you can test the restful webservices from your Outsystems application outside PowerBi. In this way you can clearly distinguish between OutSystems and PowerBI issues.

Regards,

Matthieu

Matthieu,


this sounds great, but I am new to programing and have no idea how to get started with RESTFUL apps. Do you have alink to a basic step by step tutorial?


Thanks,


Gonzalo


Hi Gonzalo,

I think Matthieu means he consumed the BI's REST services.