OutSystems drop-down selection not working as expected only in iOS when you have drop-down element within the form. Has anyone face this issue ever before?

Hi Karnan,

You're asking whether anyone has faced a certain issue, but you don't describe the issue! "not working as expected" needs some more clarification: what do you expect, and what happens instead?

Hello Kilian,

My bad, first of all it's actually not a drop-down control it's an autocomplete control. When the user start typing their address in the textbox, consumed service will return the list of address where user can select one.  The problem here is when the user access the application in iOS, then selecting the address from the autocomplete list, always the first address in list picked and displayed in the textbox, the actual one is not showing there in the textbox.


Thanks,

Hi Karnan,

Thanks for the clarification. Is this only happening on iOS? What if you test it in the browser?

Kilian Hekhuis wrote:

Hi Karnan,

Thanks for the clarification. Is this only happening on iOS? What if you test it in the browser?


Yes, It's only happening in iOS.  Actually I had verified this in iPhone and iPad with Safari & Chrome, same issue in both browsers. But it's working fine in windows with all the browsers.  

Ok, thanks for the clarification. I don't know what could be the cause, but I'll ask around.

Thank you!

HI Team,
I am facing problem in dropdown UI on IE 11. when i select the dropdown value it became wider horizontally. that menas it stretched horizontally to cover full area in IE 11 at 125% view.

it happens in entire application for dropdown menu.

can anyone help me to resolve this, 

SO is there no solution for this issue? I am having a similar problem.

I can confirm i am facing this issue as well.

On a responsive Web App, using iOS, the DropDown Select only works if you double tap inside the values only if on the page you're using the DropDown select exists a form.

Otherwise it works as expected.. This is having impact on my application as, probably, i need to get rid of all the Dropdown Select web blocks from OutSystems UI and replace with the native ones.

Michael Adams wrote:

SO is there no solution for this issue? I am having a similar problem.

Hi Michael, 

The issue was fixed and it will be released in the next days.


Thank you


Michael Adams wrote:

SO is there no solution for this issue? I am having a similar problem.

Hi Michael, 


The new version of OutSystems UI includes the fix for the DropdownSelectPattern


Thanks