[BLE Plugin] Can't Scan anything

[BLE Plugin] Can't Scan anything

  
Forge Component
(5)
Published on 25 Oct by G. Andrew Duthie
5 votes
Published on 25 Oct by G. Andrew Duthie

Hi everyone,

I'm using BLE Plugin to scan all available devices but I can't find any device.

I've also tested the BLE Plugin Demo and I can't find any device. I think what happens is that it doesn't detect that Bluetooth is enabled.

Can you help me?

Thank you.

I am experiencing something similar. When i open the demo app i get the error message saying "ble is not defined" . Can you help? Thanks!

Fábio Dias wrote:

Hi everyone,

I'm using BLE Plugin to scan all available devices but I can't find any device.

I've also tested the BLE Plugin Demo and I can't find any device. I think what happens is that it doesn't detect that Bluetooth is enabled.

Can you help me?

Thank you.

Hello Fábio. Did you solve this?


Pedro Garcia wrote:

I am experiencing something similar. When i open the demo app i get the error message saying "ble is not defined" . Can you help? Thanks!


I just discovered that Outsystems Now does not have the Cordova plugin installed for BLE. I believe that i'm not getting any scans and i have this message instead is because i am not able to access to Bluetooth interface. I can only do that with a APK, but because i'm in the free version, i cannot do this. Anyone knows a alternative for this?

 

Hi. 

It was a while ago but I think when I installed the apk everything worked fine.

Fábio Dias wrote:

Hi. 

It was a while ago but I think when I installed the apk everything worked fine.

Yes. I solved it the same way. The reason is that Outsystems Now does not support the Bluetooth interface.