Setting as identifier in Integration Studio

Setting as identifier in Integration Studio

  

Hello


I want to connect to an external database. I imported my database tables from my sql database to integration studio. Now I want to set the identifiers on each table but some fields just refuse to give me the option to set as identifier.  The option to "Set as identifier" remains disabled for some fields while others can be set. In the example that I am showing the option is disabled for the Id field but not for the ShortName field ... WHY?


Any help will be appreciated!



What are the rules for a field/attribute in sql to be set as an identity in integration studio?

Hi Vonnelize,

Only Integer, Long Integer and Text Attributes can be Identifiers. Unfortunately, your second image doesn't show the Original Type and Data Type. What are they?

Hi Killian

Thanks for your response! The field is a Long Integer, I am attaching a new screen shot ...




Thanks, that's weird (at least to me). I'll ask around to see if anyone has a clue.

Thanks Killian! I have another problem now, but will ask a new question on the forum.

Solution

At some point in the past, Identifiers could only be Integers and Text, I get the feeling the rule to decide when to gray out that option on the context menu was never updated when Long Integers became possible Identifiers (9.1+ iirc).

A work around is simply use the Identifier dropdown on the entity definition (above the Attributes table), that one doesn't seem to have any restrictions...

Solution