Customized preloader

Customized preloader

  

Hi,

I tried to implement the same code present in the attached link for a customized pre-loader, then screen successfully displaying the pre-loader functionality but, at the end it is not redirecting to the original application.Please help me on this issue.


https://www.outsystems.com/help/ServiceStudio/9.0/prefetching-resources/Customizing_the_Load_Screen_when_Prefetching_Resources.htm


Thanks and Regards,


Ekadeep

Hi Ekadeep,


 Can you provide the .oml so the community can take a deeper look at it? It is quite hard to answer without any more context!


Guilherme Dantas wrote:

Hi Ekadeep,


 Can you provide the .oml so the community can take a deeper look at it? It is quite hard to answer without any more context!


Thanks Guilherme Dantas for responding, I'm uploading pre-loader html and css files in service studio for an existing oml(Application) file.Here are the attached css snd HTML files that i have used for preloader.


Hi Kuruma,

Just so I understand correctly: you have uploaded a custom HTML and CSS on the Application's management screen in Service Center ("Operations" tab), but you are still seeing the original (standard) OutSystems preloader?

Kilian Hekhuis wrote:

Hi Kuruma,

Just so I understand correctly: you have uploaded a custom HTML and CSS on the Application's management screen in Service Center ("Operations" tab), but you are still seeing the original (standard) OutSystems preloader?

Hi Kilian Hekhuis


Not completely. yes, I am uploading through Application's management screen in Service Center ("Operations" tab) and I am able to see my customized preloader after publishing, but after showing the preloader action, it is not redirecting to the application, it is staying in that page(preloader page) itself.

Ok, thanks, that seems a different problem alltogether. I would assume it would also do this with the default preloader. Have you checked the error log to see whether something goes wrong?

Kilian Hekhuis wrote:

Ok, thaks, that seems a different problem alltogether. I would assume it would also do this with the default preloader. Have you checked the error log to see whether something goes wrong?

yes I do , but I do not find any errors, when I use default preloader , it is working successfully and when I download default loader and upload the same file, it is showing me the same problem, though I used default code.


I compared your version with the original, and I can't see any glaring errors. So, I would advise you to take the original, and make smaller changes, so you can see what change makes it go wrong.

Kilian Hekhuis wrote:

I compared your version with the original, and I can't see any glaring errors. So, I would advise you to take the original, and make smaller changes, so you can see what change makes it go wrong.

Thank you , ill try that and get back to you.


Kuruma Ekadeep wrote:

Kilian Hekhuis wrote:

I compared your version with the original, and I can't see any glaring errors. So, I would advise you to take the original, and make smaller changes, so you can see what change makes it go wrong.

Thank you , ill try that and get back to you.


Hi Kilian Hekhuis,


I do not find any difference. Please open my module link , so that you can come to know what my problem is.

http://kuruma-ekadeep.outsystemscloud.com/BaseTheme/


Please help me.


Hi Kuruma,

If the original preloader page also has this problem, I'm not sure what causes it, unfortunately.

Hello guys,


I also tried to implement the same thing mentioned above. initially, I face the same issue which is mentioned above but what I did is I just replace the old js code with this one in custom HTML file

<script type="text/javascript">
        // A list of modules to prefetch resources.
var modulesToPrefetch = ["Bookings_PP", "Bookings_PP"];

// The URL to redirect to after prefetching the resources.
var redirectUrl = "https://pankajpant824.outsystemscloud.com/Bookings_PP/Home.aspx";

// The locale of the resources to fetch.
var locale = "en-US";

// The code to be executed when receiving an update about
// the progress. It prints the progress on the console.
function PreloadProgress(percentage) {
console.log(percentage*100 + "%");
};

// Prefetches the static resources from the 'Bookings_PP' and 'Bookings_PP' modules.
outsystems.api.preloader.preloadApp(modulesToPrefetch, redirectUrl, locale, PreloadProgress);


    </script>

Test URL-https://pankajpant824.outsystemscloud.com/Bookings_PP/


Regards,

PP

pankaj pant wrote:

Hello guys,


I also tried to implement the same thing mentioned above. initially, I face the same issue which is mentioned above but what I did is I just replace the old js code with this one in custom HTML file

<script type="text/javascript">
        // A list of modules to prefetch resources.
var modulesToPrefetch = ["Bookings_PP", "Bookings_PP"];

// The URL to redirect to after prefetching the resources.
var redirectUrl = "https://pankajpant824.outsystemscloud.com/Bookings_PP/Home.aspx";

// The locale of the resources to fetch.
var locale = "en-US";

// The code to be executed when receiving an update about
// the progress. It prints the progress on the console.
function PreloadProgress(percentage) {
console.log(percentage*100 + "%");
};

// Prefetches the static resources from the 'Bookings_PP' and 'Bookings_PP' modules.
outsystems.api.preloader.preloadApp(modulesToPrefetch, redirectUrl, locale, PreloadProgress);


    </script>

Test URL-https://pankajpant824.outsystemscloud.com/Bookings_PP/


Regards,

PP


Its looking Good, could you please share your html and css file, so that ill check where I have to change my code to customize it.

Sure Kuruma,


PFA.


Thanks,

PP

Not able to aad two attachment in single post find CSS file for the same.


Regards,

PP