[Html2PdfConverter] The system cannot find the file specified
Forge component by Miguel 'Kelter' Antunes


It is my first time to HTML2PDFConverter extention. I already download  and configure it but I encountered the error below :


Here is the screen shot of the configuration :

Please help to resolve the error.

Hi Ariel,

can you try to check "Write Binaries to Running Dir" and try again?


Hi Miguel,

Thanks for the reply.I aready try it but same error occured. Our OutSystems server is not on the cloud, we have local server for this.

Hi Ariel,

If you have an on prem server and you’ve checked the box you should check the following:

1) log on to the server and check if the binaries are in the running dir of html2pdf inside a folder called binaries.

2) if they are not you can republish the espace so the binaries are written there. Check again and If they are still not there you need to analize the logs on servicecenter and possible on the eventviewer of the server to see what errors may be ocurring during the copy procedure.

3) if they are there you should run wkhtmltopdf from the command line to see if it is able to generate the pdf on your server.

Let us know how it went so we can try to understand what the problem may be.



Hi Guilherme,

I tried the steps above but I encountered another error when I applied it in web application. Please see the screen shot below :

Hi Guilherme,

Just want to add our server logs. Maybe it can help in the troubleshooting of the above error. Appreciate if we can solve the error.

Thanks and regards,



Hi Ariel,

So the component is running great.

Regarding the error the only problem that i know off that causes such error is due to an incompatibility between silk and wkhtmltopdf. In those cases what’s recommended is to create a blank page on a web flow with antheme not based on silk an use it for export.

This problem as well as the previous and some troubleshoot/workaround issues can be found in the component’s FAQ here.

Let us know if you were able to solve your issue.



We already created a seperate page without SILK UI Theme and we also set it to "anonymous". Is there anything else that we miss. Please see the screen shot below




I had that same "file not found" error and I was to solve the issue doing the following steps.

On the "<domain>/HtmlToPdfConverter/Administration.aspx" web page

1 - Set the write binaries file path: It was previously set to a "D:\" disk that didn't exist on my server machine

2 - Download and upload each file to your server

It should all work now.


Henrique Silva


I have the same problem.

I added the files of configuration in the web https://wkhtmltopdf.org/downloads.html. 

In this site I don't find the MinGW you are recomended but I added the files exists.

In my application, when I click to export pdf the action "GeneratePDF" of the extension "HtmlConvertToPdf" give this error: "The system cannot find the file specified"

Someone help me please?


The component is working well.

What I did was to eliminate all the components and install again. I uploaded the binaries and it worked. 


can you please explain the process?

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.